Page 1 of 1

Откатиться с версии 7.4 до 7.2

Posted: Sat Oct 19, 2019 3:58 pm
by Pim
Привет, подскажите, пожалуйста, как можно откатиться с версии PHP 7.4 до версии 7.2, желательно, глобально не переустанавливая VPS и весту? Стоит nginx + php-fpm конфигурация.

Re: Откатиться с версии 7.4 до 7.2

Posted: Sat Oct 19, 2019 5:09 pm
by mefish

Code: Select all

yum remove php
yum install yum-utils
yum-config-manager --enable remi-php72
yum install php
при удалении потянет кучу зависимостей !

Re: Откатиться с версии 7.4 до 7.2

Posted: Sat Nov 02, 2019 6:07 am
by clayrabbit
А это модно теперь по-умолчанию накатывать версию PHP которая даже в релиз не вышла?

Re: Откатиться с версии 7.4 до 7.2

Posted: Sat Nov 02, 2019 10:09 am
by grayfolk
clayrabbit wrote:
Sat Nov 02, 2019 6:07 am
А это модно теперь по-умолчанию накатывать версию PHP которая даже в релиз не вышла?
Спросите у разработчиков ОС, у хостера, зачем делать дефолтными репозитории с такими версиями. Веста всего лишь ставит дефолтные версии из дефолтных репозиториев.

Re: Откатиться с версии 7.4 до 7.2

Posted: Mon Nov 04, 2019 2:19 pm
by clayrabbit
grayfolk wrote:
Sat Nov 02, 2019 10:09 am
Спросите у разработчиков ОС, у хостера, зачем делать дефолтными репозитории с такими версиями. Веста всего лишь ставит дефолтные версии из дефолтных репозиториев.
Ни разработчики ОС, ни хостеры к этому не имеют отношения. remi - не дефолтный репозиторий.
По крайней мере на centos 7 сейчас установщик весты по дефолту накатывает php 7.4RC5 из remi и это совсем не хорошо.

Re: Откатиться с версии 7.4 до 7.2

Posted: Mon Nov 04, 2019 4:26 pm
by grayfolk
clayrabbit wrote:
Mon Nov 04, 2019 2:19 pm
Ни разработчики ОС, ни хостеры к этому не имеют отношения. remi - не дефолтный репозиторий.
По крайней мере на centos 7 сейчас установщик весты по дефолту накатывает php 7.4RC5 из remi и это совсем не хорошо.
Как минимум, вы можете не устанавливать remi:
Image

Re: Откатиться с версии 7.4 до 7.2

Posted: Sun Feb 23, 2020 9:14 am
by Smartik
Здравствуйте, установил без remi, спасибо.
php 5.4.16 стоит в системе.

Можете подсказать теперь как правильно его обновить до php 7.3 ?
Спасибо.

Update!

Я нашел мануал, по которому - поставил centos 7, поставил vesta без remi, обновил php c 5.4.16 до 7.3.15
На скрине команды, которые позволили это сделать. Всё работает без проблем.
Image

Re: Откатиться с версии 7.4 до 7.2

Posted: Sun Feb 23, 2020 9:17 am
by grayfolk
Smartik wrote:
Sun Feb 23, 2020 9:14 am
Здравствуйте, установил без remi, спасибо.
php 5.4.16 стоит в системе.

Можете подсказать теперь как правильно его обновить до php 7.3 ?
Спасибо.
Поищите по форуму, многократно обсуждалось, даже туториалы писались.
Принцип простой: отключаете все версии, включаете нужную, и обновляетесь.

P.S. Кстати, почему 7.3? 7.4 уже актуальная версия, рекомендую.

Re: Откатиться с версии 7.4 до 7.2

Posted: Sun Feb 23, 2020 9:33 am
by Smartik
grayfolk wrote:
Sun Feb 23, 2020 9:17 am
Smartik wrote:
Sun Feb 23, 2020 9:14 am
Здравствуйте, установил без remi, спасибо.
php 5.4.16 стоит в системе.

Можете подсказать теперь как правильно его обновить до php 7.3 ?
Спасибо.
Поищите по форуму, многократно обсуждалось, даже туториалы писались.
Принцип простой: отключаете все версии, включаете нужную, и обновляетесь.

P.S. Кстати, почему 7.3? 7.4 уже актуальная версия, рекомендую.
Спасибо за ответ, я обновил свой пост, посмотрите пожалуйста, правильно же сделал?
7.4 не поддерживает ioncube loader (может пригодится для парочки сайтов)