Page 1 of 1

VestacP:8083+Nginx+CloudFlare Flexible SSL> Connection refused

Posted: Mon Jan 02, 2017 10:29 am
by MAN5
Im using VestaCP , Nginx, Debian 14x.
All my websites working in http mode well.
Than, i used CF Flexible SSL option to use https. And all my sites works.

(Note : i never change any setting on VestaCP for this CF Flexible SSL to work & is works fine)

Till now, im using self signes default vestacp installation only for my admin panel:8083. im seeing more nagging screens on firefox , chrome about my original vestaCP self signed cert issues. So i planned to use the same Cloudflare ssl, but all my browsers shows ' Connection refused'.

I tried to activate letsencrypt ssl.

Today tried to use my other domains - works well.
tried - success.
but my server hostname - > shows invalid IP.

Both using cloudflare DNS.
I tried delete/recreate the on VestaCP - still issues for Letsencrypt-SSL

Any advise ?

Re: VestacP:8083+Nginx+CloudFlare Flexible SSL> Connection refused

Posted: Wed Jan 18, 2017 12:20 pm
by MAN5
I was struggled a lot for this letsencrypt to work. As of my issue, i went thru that url path inside my 'wellknows>acme' path, the new strings url there but additionally few letters also added into it. May be thats why the LE cant find the required url. May be im wrong.

But im using Webmin for my server management. (Note: all my domain, DNS, email etc maintained by VestaCP)
I used webmin to generate SSL for my domain. It works charm. Also i copied those ssl cert, key into my vestacp:8083 also. Works fine.