Page 1 of 1

SFTP and JailKit not working

Posted: Fri Jan 20, 2017 10:14 am
by kronz
SFTP Chroot and Jailkit are not working.

I restarted the server several times and still no chroot.

Additionally I encountered the following problem following the instructions from this thread:
Download all the files located on the GitHub repository folder /bin
Open the file v-add-sys-sftp-jail with your desired editor
Search for /sbin/jk_init
Modify the following lines as you prefeer and save the file: > You must specify which packages the user should be able to use here.

/sbin/jk_init -f -j $chroot basicshell editors extendedshell netutils ssh sftp scp git
/sbin/jk_cp -f -j $chroot /bin/id

Modify /etc/jailkit/jk_init.ini as you prefeer
1. Can't find the line containing /sbin/jk_init
2. Do I need to modify /etc/jailkit/jk_init.ini in order to get it to work and how do I modify it ?

I am sorry for posting in the wrong forum, but I still have no access to the PLUGINS forum although I paid for Chroot.

Re: SFTP and JailKit not working

Posted: Fri Jan 20, 2017 12:03 pm
by mike08
Try modifying the scripts to include /usr/sbin/jk_init instead, as /usr/sbin/jk_init doesn't exist in Debian based systems.

Re: SFTP and JailKit not working

Posted: Fri Jan 20, 2017 1:35 pm
by kronz
Did that and reinstalled the script. Still not working.

Re: SFTP and JailKit not working

Posted: Sun Jan 22, 2017 11:14 am
by kronz
It's not Jailkit's fault. I can confirm that the SFTP CHROOT extension is not working at all.

I reinstalled the WHOLE system and the extension still doesn't work!


EDIT: I still don't know what lines to edit in v-add-sys-sftp-jail. The line specified does not exist
EDIT: I broke SFTP Chroot trying to install Jailkit. Now SFTP Chroot doesn't work.

Re: SFTP and JailKit not working

Posted: Sat Apr 22, 2017 10:54 am
by youradds

How did you get this going? I can login with SCP, but SFTP just breaks (it gets into starting the session in WinSCP, but then closes). If I change the account over to use SCP then it works, but I can navigate around the whole filesystem, even when not logged in as root :/

Any ideas? The weird thing, is that SFTP *was* working fine, but it has since stopped.



Re: SFTP and JailKit not working

Posted: Sat Aug 25, 2018 9:02 pm
by Las
System: Debian Stretch 9.5

Problem: JailKit doesn't work after VestaCP installation.

Content of rc.local created by VestaCP:

Code: Select all

Solution: Need to add hashpling into rc.local:

Code: Select all