Page 2 of 8

Re: Ubuntu 18.04 Support ETA

Posted: Mon Aug 06, 2018 9:17 pm
by alexcy
Seems that the next version is postponed for end September according to roadmap? And no mention of Ubuntu 18.04 support at all!

That's very unfortunate.

Re: Ubuntu 18.04 Support ETA

Posted: Mon Aug 06, 2018 9:20 pm
by imperio
Ubuntu 18.04 already supported

Re: Ubuntu 18.04 Support ETA

Posted: Mon Aug 06, 2018 9:21 pm
by alexcy
When that happened?

Re: Ubuntu 18.04 Support ETA

Posted: Mon Aug 06, 2018 9:28 pm
by imperio
alexcy wrote:
Mon Aug 06, 2018 9:21 pm
When that happened?
about two months ago

Re: Ubuntu 18.04 Support ETA

Posted: Mon Aug 06, 2018 9:43 pm
by alexcy
Well, there are issues then when the installer that have to be resolved.

Re: Ubuntu 18.04 Support ETA

Posted: Mon Aug 06, 2018 9:49 pm
by alexcy
dbconfig-common: writing config to /etc/dbconfig-common/roundcube.conf
Creating config file /etc/dbconfig-common/roundcube.conf with new version
Creating config file /etc/roundcube/debian-db.php with new version
checking privileges on database roundcube for roundcube@localhost: user creation needed.
granting access to database roundcube for roundcube@localhost: failed.
error encountered creating user:
mysql said: ERROR 1044 (42000) at line 1: Access denied for user 'debian-sys-maint'@'localhost' to database 'roundcube'
dbconfig-common: roundcube configure: noninteractive fail.
dbconfig-common: roundcube configure: ignoring errors from here forwards

Creating config file /etc/phpmyadmin/config-db.php with new version
checking privileges on database phpmyadmin for phpmyadmin@localhost: user creation needed.
granting access to database phpmyadmin for phpmyadmin@localhost: failed.
error encountered creating user:
mysql said: ERROR 1044 (42000) at line 1: Access denied for user 'debian-sys-maint'@'localhost' to database 'phpmyadmin'
dbconfig-common: phpmyadmin configure: noninteractive fail.
dbconfig-common: phpmyadmin configure: ignoring errors from here forwards
populating database via sql... done.
dbconfig-common: flushing administrative password
Setting up php (1:7.2+60ubuntu1) ...
Setting up sa-compile (3.4.1-8build1) ...

Processing triggers for systemd (237-3ubuntu10) ...
Processing triggers for dovecot-core (1:2.2.33.2-1ubuntu4.1) ...
Installing MySQL system tables in '/var/lib/mysql' ...
Installation of system tables failed! Examine the logs in
/var/lib/mysql for more information.
The problem could be conflicting information in an external
my.cnf files. You can ignore these by doing:
shell> /usr/bin/mysql_install_db --defaults-file=~/.my.cnf
You can also try to start the mysqld daemon with:
shell> /usr/sbin/mysqld --skip-grant-tables --general-log &
and use the command line tool /usr/bin/mysql
to connect to the mysql database and look at the grant tables:
shell> /usr/bin/mysql -u root mysql
mysql> show tables;
Try 'mysqld --help' if you have problems with paths. Using
--general-log gives you a log in /var/lib/mysql that may be helpful.

mkdir: cannot create directory â/var/lib/mysqlâ: File exists
Setting /usr/sbin/named to complain mode.
Adding user Debian-exim to group mail
Adding user dovecot to group mail
Job for dovecot.socket failed.
See "systemctl status dovecot.socket" and "journalctl -xe" for details.
Adding user clamav to group mail
Adding user clamav to group Debian-exim
Synchronizing state of spamassassin.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable spamassassin
mv: cannot move '/usr/local/vesta/data/ips/' to a subdirectory of itself, '/usr/local/vesta/data/ips/xxx.xxx.xxx.xxx'
sed: can't read /usr/local/vesta/data/users/*/dns/*.conf: No such file or directory
sed: -e expression #1, char 0: no previous regular expression
sed: -e expression #1, char 0: no previous regular expression

exim: failed to find uid for user name "Debian-exim"

Job for vesta.service failed because the control process exited with error code. failed!
[....] Restarting vesta (via systemctl): vesta.serviceJob for vesta.service failed becaus$
Jun 29 01:06:35 hostname vesta2661: /etc/init.d/vesta: 31: .: Can't open /etc/profile.d/vesta.sh

Job for dovecot.socket failed.
See "systemctl status dovecot.socket" and "journalctl -xe" for details.

Re: Ubuntu 18.04 Support ETA

Posted: Tue Aug 07, 2018 8:03 pm
by alexcy
What do you think? As far as I can see from this forum, everyone is still expecting the 18.04 support. Some users have tried installing Vesta on 18.04 but also had several issues.

Any ideas?

Re: Ubuntu 18.04 Support ETA

Posted: Wed Aug 08, 2018 7:55 am
by ScIT
alexcy wrote:
Tue Aug 07, 2018 8:03 pm
What do you think? As far as I can see from this forum, everyone is still expecting the 18.04 support. Some users have tried installing Vesta on 18.04 but also had several issues.

Any ideas?
Vesta Core Team posted on facebook, that Ubuntu 18.04 is supported now a few days ago -> http://vestacp.com/install/

Re: Ubuntu 18.04 Support ETA

Posted: Wed Aug 08, 2018 8:47 am
by plutocrat
I just tried another installation on a fresh Ubuntu 18.04 server on Digital Ocean. There were a few errors thrown during the install, but most of them were working at the end of the install, in particular the errors for vesta, mysql, and phpmyadmin.
systemctl status vesta, and systemctl status mysql were fine. The error thrown by phpmyadmin was, it seems due to trying to install the package when it had already been installed: it does in fact work fine.
I created a webdomain, activated Letsencrypt SSL, installed an app with Softilicious. All seemed OK.

The only issue I did find was with roundcube, which 'fails to connect' to the database. I found a password here:
grep dbc_dbpass /etc/dbconfig-common/roundcube.conf

And changed the one in mysql to that value.
set password for roundcube@localhost = PASSWORD('ioodsfsdofds');

Then I was able to connect. However I couldn't login to roundcube with the email address I set up: there's a new login field called 'server' and it didn't like localhost, 127.0.0.1, myserver.domain.com or anything else I tried.

So out of all the errors, it only seems like roundcube that didn't fully work. Abridged install log below.

Code: Select all

root@eighteen:~# groupdel admin
root@eighteen:~# bash vst-install.sh 
--2018-08-08 07:41:02--  http://vestacp.com/pub/vst-install-ubuntu.sh
Resolving vestacp.com (vestacp.com)... 104.236.66.100
Connecting to vestacp.com (vestacp.com)|104.236.66.100|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/plain]
Saving to: ‘vst-install-ubuntu.sh’

vst-install-ubuntu.sh        [ <=>                               ]  44.49K  --.-KB/s    in 0.001s  

2018-08-08 07:41:02 (44.8 MB/s) - ‘vst-install-ubuntu.sh’ saved [45556]



 _|      _|  _|_|_|_|    _|_|_|  _|_|_|_|_|    _|_|
 _|      _|  _|        _|            _|      _|    _|
 _|      _|  _|_|_|      _|_|        _|      _|_|_|_|
   _|  _|    _|              _|      _|      _|    _|
     _|      _|_|_|_|  _|_|_|        _|      _|    _|

                                  Vesta Control Panel



The following software will be installed on your system:
   - Nginx Web Server
   - Apache Web Server (as backend)
   - Bind DNS Server
   - Exim Mail Server
   - Dovecot POP3/IMAP Server
   - MySQL Database Server
   - Vsftpd FTP Server
   - Softaculous Plugin
   - Iptables Firewall + Fail2Ban


Would you like to continue [y/n]: y
Please enter admin email address: mail@domain.com
Please enter FQDN hostname [eighteen.domain.com]: 
Installation backup directory: /root/vst_install_backups/1533714090




Installation will take about 15 minutes ...

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following package was automatically installed and is no longer required:
  grub-pc-bin
Use 'apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
--2018-08-08 07:41:36--  http://nginx.org/keys/nginx_signing.key
Resolving nginx.org (nginx.org)... 206.251.255.63, 95.211.80.227, 2001:1af8:4060:a004:21::e3, ...
Connecting to nginx.org (nginx.org)|206.251.255.63|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1561 (1.5K) [text/plain]
Saving to: ‘/tmp/nginx_signing.key’

/tmp/nginx_signing.key   100%[==================================>]   1.52K  --.-KB/s    in 0s      

2018-08-08 07:41:36 (143 MB/s) - ‘/tmp/nginx_signing.key’ saved [1561/1561]

OK
--2018-08-08 07:41:36--  http://c.vestacp.com/deb_signing.key
Resolving c.vestacp.com (c.vestacp.com)... 104.236.66.100
Connecting to c.vestacp.com (c.vestacp.com)|104.236.66.100|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1719 (1.7K) [text/plain]
Saving to: ‘deb_signing.key’

deb_signing.key          100%[==================================>]   1.68K  --.-KB/s    in 0s      

2018-08-08 07:41:36 (233 MB/s) - ‘deb_signing.key’ saved [1719/1719]

OK
Get:1 http://apt.vestacp.com/bionic bionic InRelease [2187 B]
Get:2 http://apt.vestacp.com/bionic bionic/vesta amd64 Packages [1004 B]                                                                                                          
Hit:4 http://security.ubuntu.com/ubuntu bionic-security InRelease                          
Hit:3 http://nyc2.mirrors.digitalocean.com/ubuntu bionic InRelease                                                                      
Get:5 http://nginx.org/packages/mainline/ubuntu bionic InRelease [2112 B]                                                               
Hit:6 http://nyc2.mirrors.digitalocean.com/ubuntu bionic-updates InRelease
Hit:7 http://nyc2.mirrors.digitalocean.com/ubuntu bionic-backports InRelease
Get:8 http://nginx.org/packages/mainline/ubuntu bionic/nginx amd64 Packages [10.0 kB]
Fetched 15.3 kB in 1s (26.4 kB/s)                  
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
bc is already the newest version (1.07.1-2).
bsdmainutils is already the newest version (11.1.2ubuntu1).
cron is already the newest version (3.0pl1-128.1ubuntu1).
e2fsprogs is already the newest version (1.44.1-1).
ftp is already the newest version (0.17-34).
lsof is already the newest version (4.89+dfsg-0.1).
sudo is already the newest version (1.8.21p2-3ubuntu1).
vim-common is already the newest version (2:8.0.1453-1ubuntu1).
bsdutils is already the newest version (1:2.31.1-0.4ubuntu3.1).
curl is already the newest version (7.58.0-2ubuntu3.2).
dnsutils is already the newest version (1:9.11.3+dfsg-1ubuntu1.1).
git is already the newest version (1:2.17.1-1ubuntu0.1).
The following package was automatically installed and is no longer required:
  grub-pc-bin
Use 'apt autoremove' to remove it.
The following additional packages will be installed:
  apache2-bin apache2-data aspell aspell-en bind9utils binutils binutils-common binutils-x86-64-linux-gnu cpp cpp-7 dbconfig-common dbconfig-mysql dictionaries-common dovecot-core emacsen-common
  exim4-base exim4-config fontconfig fontconfig-config fonts-dejavu-core fonts-droid-fallback fonts-noto-mono gcc gcc-7 gcc-7-base ghostscript gsfonts guile-2.0-libs hicolor-icon-theme
  imagemagick-6-common imagemagick-6.q16 javascript-common libaio1 libapache2-mod-php7.2 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libasan4 libaspell15 libatomic1
  libavahi-client3 libavahi-common-data libavahi-common3 libbinutils libc-dev-bin libc6-dev libcairo2 libcc1-0 libcgi-fast-perl libcgi-pm-perl libcilkrts5 libcups2 libcupsfilters1 libcupsimage2
  libdatrie1 libdbi1 libdjvulibre-text libdjvulibre21 libencode-locale-perl libevent-core-2.1-6 libexttextcat-2.0-0 libexttextcat-data libfcgi-perl libfftw3-double3 libfl-dev libfl2 libfontconfig1
  libgc1c2 libgcc-7-dev libgd3 libgomp1 libgraphite2-3 libgs9 libgs9-common libgsasl7 libharfbuzz0b libhtml-parser-perl libhtml-tagset-perl libhtml-template-perl libhttp-date-perl
  libhttp-message-perl libijs-0.35 libilmbase12 libio-html-perl libisl19 libitm1 libjbig0 libjbig2dec0 libjpeg-turbo8 libjpeg8 libjs-jquery libjs-sphinxdoc libjs-underscore libkyotocabinet16v5
  liblcms2-2 liblqr-1-0 liblsan0 libltdl7 liblua5.2-0 liblwp-mediatypes-perl libmagickcore-6.q16-3 libmagickcore-6.q16-3-extra libmagickwand-6.q16-3 libmailutils5 libmpc3 libmpx2 libmysqlclient20
  libnet-xwhois-perl libnetpbm10 libnl-3-200 libnl-genl-3-200 libntlm0 libopenexr22 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpaper-utils libpaper1 libpixman-1-0 libpq5
  libpython-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib libquadmath0 librrd8 libsodium23 libssh2-1 libtcl8.6 libthai-data libthai0 libtiff5 libtimedate-perl libtirpc1 libtsan0
  libubsan0 liburi-perl libwebp6 libwmf0.2-7 libxcb-render0 libxcb-shm0 libxpm4 libxrender1 libzip4 linux-libc-dev m4 mailutils mailutils-common manpages-dev mc-data mysql-client-5.7
  mysql-client-core-5.7 mysql-server-5.7 mysql-server-core-5.7 netpbm php php-auth-sasl php-bz2 php-gd php-intl php-mail-mime php-mbstring php-net-sieve php-net-smtp php-net-socket php-pear
  php-php-gettext php-phpseclib php-pspell php-tcpdf php-xml php-zip php7.2 php7.2-bz2 php7.2-cgi php7.2-cli php7.2-common php7.2-curl php7.2-gd php7.2-intl php7.2-json php7.2-mbstring
  php7.2-mysql php7.2-opcache php7.2-pspell php7.2-readline php7.2-xml php7.2-zip poppler-data python python-minimal python2.7 python2.7-minimal python3-apparmor python3-libapparmor python3-ply
  python3-pyinotify ssl-cert tcl-expect tcl8.6 unzip
Suggested packages:
  www-browser apache2-doc vim-addon-manager aspell-doc spellutils libnet-dns-perl libnet-ip-perl libgeo-ipfree-perl bind9-doc resolvconf binutils-doc cpp-doc gcc-7-locales wordlist dovecot-gssapi
  dovecot-ldap dovecot-lmtpd dovecot-managesieved dovecot-mysql dovecot-pgsql dovecot-sieve dovecot-solr dovecot-sqlite ntp eximon4 exim4-doc-html | exim4-doc-info spf-tools-perl swaks tk8.6 monit
  sqlite3 bison build-essential flex-doc fonts-noto gcc-multilib make autoconf automake libtool gdb gcc-doc gcc-7-multilib gcc-7-doc libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg
  libasan4-dbg liblsan0-dbg libtsan0-dbg libubsan0-dbg libcilkrts5-dbg libmpx2-dbg libquadmath0-dbg ghostscript-x imagemagick-doc autotrace cups-bsd | lpr | lprng enscript ffmpeg gimp gnuplot
  grads graphviz hp2xx html2ps libwmf-bin mplayer povray radiance sane-utils texlive-base-bin transfig ufraw-batch xdg-utils glibc-doc cups-common libfftw3-bin libfftw3-dev libgd-tools
  libdata-dump-perl libipc-sharedcache-perl liblcms2-utils inkscape libjxr-tools libwww-perl libwmf0.2-7-gtk m4-doc mailutils-mh mailutils-doc arj catdvi | texlive-binaries dbview djvulibre-bin
  genisoimage gv libaspell-dev links | w3m | lynx odt2txt poppler-utils python-boto python-tz xpdf | pdf-viewer tinyca php-libsodium php-mcrypt php-gmp php-imagick fonts-japanese-mincho
  | fonts-ipafont-mincho fonts-japanese-gothic | fonts-ipafont-gothic fonts-arphic-ukai fonts-arphic-uming fonts-nanum python-doc python-tk python2.7-doc binfmt-support python-ply-doc
  python-pyinotify-doc libnet-ldap-perl rpcbind php-net-ldap2 php-crypt-gpg php-net-ldap3 mariadb-server | default-mysql-server librrds-perl cvs makejail rdist subversion openssl-blacklist
  tcl-tclreadline ttf-dejavu-core | ttf-bitstream-vera | ttf-freefont
The following NEW packages will be installed:
  apache2 apache2-bin apache2-data apache2-suexec-custom apache2-utils apparmor-utils aspell aspell-en awstats bind9 bind9utils binutils binutils-common binutils-x86-64-linux-gnu cpp cpp-7
  dbconfig-common dbconfig-mysql dictionaries-common dovecot-core dovecot-imapd dovecot-pop3d e2fslibs emacsen-common exim4 exim4-base exim4-config exim4-daemon-heavy expect fail2ban flex
  fontconfig fontconfig-config fonts-dejavu-core fonts-droid-fallback fonts-noto-mono gcc gcc-7 gcc-7-base ghostscript gsfonts guile-2.0-libs hicolor-icon-theme idn imagemagick
  imagemagick-6-common imagemagick-6.q16 javascript-common libaio1 libapache2-mod-fcgid libapache2-mod-php libapache2-mod-php7.2 libapache2-mod-rpaf libapache2-mod-ruid2 libapr1 libaprutil1
  libaprutil1-dbd-sqlite3 libaprutil1-ldap libasan4 libaspell15 libatomic1 libavahi-client3 libavahi-common-data libavahi-common3 libbinutils libc-dev-bin libc6-dev libcairo2 libcc1-0
  libcgi-fast-perl libcgi-pm-perl libcilkrts5 libcups2 libcupsfilters1 libcupsimage2 libdatrie1 libdbi1 libdjvulibre-text libdjvulibre21 libencode-locale-perl libevent-core-2.1-6
  libexttextcat-2.0-0 libexttextcat-data libfcgi-perl libfftw3-double3 libfl-dev libfl2 libfontconfig1 libgc1c2 libgcc-7-dev libgd3 libgomp1 libgraphite2-3 libgs9 libgs9-common libgsasl7
  libharfbuzz0b libhtml-parser-perl libhtml-tagset-perl libhtml-template-perl libhttp-date-perl libhttp-message-perl libijs-0.35 libilmbase12 libio-html-perl libisl19 libitm1 libjbig0 libjbig2dec0
  libjpeg-turbo8 libjpeg8 libjs-jquery libjs-sphinxdoc libjs-underscore libkyotocabinet16v5 liblcms2-2 liblqr-1-0 liblsan0 libltdl7 liblua5.2-0 liblwp-mediatypes-perl libmagickcore-6.q16-3
  libmagickcore-6.q16-3-extra libmagickwand-6.q16-3 libmailutils5 libmpc3 libmpx2 libmysqlclient20 libnet-xwhois-perl libnetpbm10 libnl-3-200 libnl-genl-3-200 libntlm0 libopenexr22 libpango-1.0-0
  libpangocairo-1.0-0 libpangoft2-1.0-0 libpaper-utils libpaper1 libpixman-1-0 libpq5 libpython-stdlib libpython2.7 libpython2.7-minimal libpython2.7-stdlib libquadmath0 librrd8 libsodium23
  libssh2-1 libtcl8.6 libthai-data libthai0 libtiff5 libtimedate-perl libtirpc1 libtsan0 libubsan0 liburi-perl libwebp6 libwmf0.2-7 libxcb-render0 libxcb-shm0 libxpm4 libxrender1 libzip4
  linux-libc-dev m4 mailutils mailutils-common manpages-dev mc mc-data mysql-client mysql-client-5.7 mysql-client-core-5.7 mysql-common mysql-server mysql-server-5.7 mysql-server-core-5.7 netpbm
  nginx ntpdate php php-auth-sasl php-bz2 php-cgi php-common php-curl php-gd php-intl php-mail-mime php-mbstring php-mysql php-net-sieve php-net-smtp php-net-socket php-pear php-php-gettext
  php-phpseclib php-pspell php-tcpdf php-xml php-zip php7.2 php7.2-bz2 php7.2-cgi php7.2-cli php7.2-common php7.2-curl php7.2-gd php7.2-intl php7.2-json php7.2-mbstring php7.2-mysql php7.2-opcache
  php7.2-pspell php7.2-readline php7.2-xml php7.2-zip phpmyadmin poppler-data python python-minimal python2.7 python2.7-minimal python3-apparmor python3-libapparmor python3-ply python3-pyinotify
  quota roundcube-core roundcube-mysql roundcube-plugins rrdtool rssh ssl-cert tcl-expect tcl8.6 unzip vesta vesta-ioncube vesta-nginx vesta-php vesta-softaculous vsftpd webalizer whois zip
0 upgraded, 248 newly installed, 0 to remove and 0 not upgraded.
Need to get 172 MB of archives.
After this operation, 571 MB of additional disk space will be used.
Get:1 http://apt.vestacp.com/bionic bionic/vesta amd64 vesta amd64 0.9.8-22 [1972 kB]
Get:2 http://apt.vestacp.com/bionic bionic/vesta amd64 vesta-php amd64 0.9.8-22 [34.1 MB]                                        

--------- all packages got without error ----------

Get:246 http://nyc2.mirrors.digitalocean.com/ubuntu bionic/universe amd64 phpmyadmin all 4:4.6.6-5 [3861 kB]                                                                                         
Get:247 http://nyc2.mirrors.digitalocean.com/ubuntu bionic/main amd64 rrdtool amd64 1.7.0-1build1 [367 kB]                                                                                           
Get:248 http://nyc2.mirrors.digitalocean.com/ubuntu bionic/main amd64 vsftpd amd64 3.0.3-9build1 [115 kB]                                                                                            
Fetched 172 MB in 18s (9727 kB/s)                                                                                                                                                                    
Extracting templates from packages: 100%
Preconfiguring packages ...
Selecting previously unselected package libapr1:amd64.
(Reading database ... 90586 files and directories currently installed.)
Preparing to unpack .../00-libapr1_1.6.3-2_amd64.deb ...
Unpacking libapr1:amd64 (1.6.3-2) ...

---------- all packages unpacked ok, except -------------

Selecting previously unselected package roundcube-core.
Preparing to unpack .../033-roundcube-core_1.3.6+dfsg.1-1_all.deb ...
W: use of dbc preinst hooks is now unnecesary and deprecated.
Unpacking roundcube-core (1.3.6+dfsg.1-1) ...


Setting up vesta-nginx (0.9.8-22) ...
Job for vesta.service failed because the control process exited with error code.
See "systemctl status vesta.service" and "journalctl -xe" for details.
invoke-rc.d: initscript vesta, action "start" failed.
● vesta.service - LSB: starts the vesta control panel
   Loaded: loaded (/etc/init.d/vesta; generated)
   Active: failed (Result: exit-code) since Wed 2018-08-08 07:42:47 UTC; 12ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 17490 ExecStart=/etc/init.d/vesta start (code=exited, status=2)

Aug 08 07:42:47 eighteen systemd[1]: Starting LSB: starts the vesta control panel...
Aug 08 07:42:47 eighteen vesta[17490]: /etc/init.d/vesta: 31: .: Can't open /etc/profile.d/vesta.sh
Aug 08 07:42:47 eighteen systemd[1]: vesta.service: Control process exited, code=exited status=2
Aug 08 07:42:47 eighteen systemd[1]: vesta.service: Failed with result 'exit-code'.
Aug 08 07:42:47 eighteen systemd[1]: Failed to start LSB: starts the vesta control panel.


Setting up vesta-php (0.9.8-22) ...
[....] Restarting vesta (via systemctl): vesta.serviceJob for vesta.service failed because the control process exited with error code.
See "systemctl status vesta.service" and "journalctl -xe" for details.
 failed!


Setting up javascript-common (11) ...
Package apache2 is not configured yet. Will defer actions by package javascript-common.

Setting up libapache2-mod-rpaf (0.6-13) ...
Package apache2 is not configured yet. Will defer actions by package libapache2-mod-rpaf.


Setting up roundcube-core (1.3.6+dfsg.1-1) ...
Determining localhost credentials from /etc/mysql/debian.cnf: succeeded.
dbconfig-common: writing config to /etc/dbconfig-common/roundcube.conf

Creating config file /etc/dbconfig-common/roundcube.conf with new version

Creating config file /etc/roundcube/debian-db.php with new version
checking privileges on database roundcube for roundcube@localhost: user creation needed.
granting access to database roundcube for roundcube@localhost: success.
verifying access for roundcube@localhost: success.
creating database roundcube: success.
verifying database roundcube exists: success.
populating database via sql...  done.
dbconfig-common: flushing administrative password
apache2_invoke: Enable configuration roundcube.conf
Setting up roundcube-plugins (1.3.6+dfsg.1-1) ...
Setting up ghostscript (9.22~dfsg+1-0ubuntu1.1) ...
Setting up libpangoft2-1.0-0:amd64 (1.40.14-1) ...
Setting up phpmyadmin (4:4.6.6-5) ...
Determining localhost credentials from /etc/mysql/debian.cnf: succeeded.
dbconfig-common: writing config to /etc/dbconfig-common/phpmyadmin.conf

Creating config file /etc/dbconfig-common/phpmyadmin.conf with new version

Creating config file /etc/phpmyadmin/config-db.php with new version
checking privileges on database phpmyadmin for phpmyadmin@localhost: user creation needed.
granting access to database phpmyadmin for phpmyadmin@localhost: success.
verifying access for phpmyadmin@localhost: success.
creating database phpmyadmin: success.
verifying database phpmyadmin exists: success.
populating database via sql...  done.
dbconfig-common: flushing administrative password


2018-08-08 07:44:21 [WARNING] mysql_install_db is deprecated. Please consider switching to mysqld --initialize
2018-08-08 07:44:21 [ERROR]   The data directory needs to be specified.
mkdir: cannot create directory ‘/var/lib/mysql’: File exists
2018-08-08T07:44:21.257643Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2018-08-08T07:44:21.259865Z 0 [ERROR] --initialize specified but the data directory has files in it. Aborting.
2018-08-08T07:44:21.259990Z 0 [ERROR] Aborting

mysqladmin: [Warning] Using a password on the command line interface can be insecure.
Warning: Since password will be sent to server in plain text, use ssl connection to ensure password safety.
ERROR 1054 (42S22) at line 1: Unknown column 'password' in 'where clause'


Adding user Debian-exim to group mail
Adding user dovecot to group mail
Job for dovecot.socket failed.
See "systemctl status dovecot.socket" and "journalctl -xe" for details.
ERROR 1007 (HY000) at line 1: Can't create database 'roundcube'; database exists
ERROR 1050 (42S01) at line 8: Table 'session' already exists

=======================================================

 _|      _|  _|_|_|_|    _|_|_|  _|_|_|_|_|    _|_|   
 _|      _|  _|        _|            _|      _|    _| 
 _|      _|  _|_|_|      _|_|        _|      _|_|_|_| 
   _|  _|    _|              _|      _|      _|    _| 
     _|      _|_|_|_|  _|_|_|        _|      _|    _| 


Congratulations, you have just successfully installed Vesta Control Panel

    https://12.23.34.45:8083
    username: admin
    password: xxxxxxx

We hope that you enjoy your installation of Vesta. Please feel free to contact us anytime if you have any questions.
Thank you.

--
Sincerely yours
vestacp.com team

Re: Ubuntu 18.04 Support ETA

Posted: Wed Aug 08, 2018 9:00 am
by alexcy
Thanks for your reply. Like I said before, there are still issues. I have installed Vesta on Ubuntu 18.04 in both OVH & Hetzner. Here are the foundings:

1) Vesta script didn't recognize Ubuntu as the OS and downloaded the RHEL script (OVH only)


2) Roundcube error
DATABASE ERROR: CONNECTION FAILED!
Unable to connect to the database!
Please contact your server-administrator.

This is caused because of this error during installation:
ERROR 1007 (HY000) at line 1: Can't create database 'roundcube'; database exists
ERROR 1050 (42S01) at line 8: Table 'session' already exists


3) During installation:
Setting up clamav-base (0.100.1+dfsg-1ubuntu0.18.04.2) ...
id: ‘clamav’: no such user


4) Issue starting Vesta during installation - vesta-nginx (after the setup is finished it looked ok)
Setting up vesta-nginx (0.9.8-22) ...
Job for vesta.service failed because the control process exited with error code.
See "systemctl status vesta.service" and "journalctl -xe" for details.
invoke-rc.d: initscript vesta, action "start" failed.
● vesta.service - LSB: starts the vesta control panel
Loaded: loaded (/etc/init.d/vesta; generated)
Active: failed (Result: exit-code) since Wed 2018-08-08 08:37:34 UTC; 8ms ago
Docs: man:systemd-sysv-generator(8)
Process: 30502 ExecStart=/etc/init.d/vesta start (code=exited, status=2)
Aug 08 08:37:34 ns3362606 systemd[1]: Starting LSB: starts the vesta control panel...
Aug 08 08:37:34 ns3362606 vesta[30502]: /etc/init.d/vesta: 31: .: Can't open /etc/profile.d/vesta.sh
Aug 08 08:37:34 ns3362606 systemd[1]: vesta.service: Control process exited, code=exited status=2
Aug 08 08:37:34 ns3362606 systemd[1]: vesta.service: Failed with result 'exit-code'.
Aug 08 08:37:34 ns3362606 systemd[1]: Failed to start LSB: starts the vesta control panel.


5) Another issue starting Vesta during installation - vesta-php
Setting up vesta-php (0.9.8-22) ...
[....] Restarting vesta (via systemctl): vesta.serviceJob for vesta.service failed because the control process exited with error code.
See "systemctl status vesta.service" and "journalctl -xe" for details.
failed!


6) MySQL issue:
2018-08-08 08:40:18 [WARNING] mysql_install_db is deprecated. Please consider switching to mysqld --initialize
2018-08-08 08:40:18 [ERROR] The data directory needs to be specified.
mkdir: cannot create directory ‘/var/lib/mysql’: File exists
2018-08-08T08:40:18.262171Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2018-08-08T08:40:18.265147Z 0 [ERROR] --initialize specified but the data directory has files in it. Aborting.
2018-08-08T08:40:18.265174Z 0 [ERROR] Aborting

mysqladmin: [Warning] Using a password on the command line interface can be insecure.
Warning: Since password will be sent to server in plain text, use ssl connection to ensure password safety.
ERROR 1054 (42S22) at line 1: Unknown column 'password' in 'where clause'


7) Dovecot issue:
Adding user Debian-exim to group mail
Adding user dovecot to group mail
Job for dovecot.socket failed.
See "systemctl status dovecot.socket" and "journalctl -xe" for details.


8) Freshclam issue: (I have submitted a fix on GitHub but it is still open)
ERROR: Problem with internal logger (UpdateLogFile = /var/log/clamav/freshclam.log).
ERROR: /var/log/clamav/freshclam.log is locked by another process


9) Minor warning:
Warning: apt-key output should not be parsed (stdout is not a terminal)

10) Minor warning:
W: use of dbc preinst hooks is now unnecesary and deprecated.

11) IP issue:
mv: cannot move '/usr/local/vesta/data/ips/' to a subdirectory of itself, '/usr/local/vesta/data/ips/37.187.73.103'

12) Other issue:
sed: can't read /usr/local/vesta/data/users/*/dns/*.conf: No such file or directory
sed: -e expression #1, char 0: no previous regular expression
sed: -e expression #1, char 0: no previous regular expression


13) I didn't receive an email from Vesta at the end of the installation with credentials etc.


I believe that the most important ones that need to be addressed ASAP are points 2 & 6. Until the above are fixed, I believe that we can't claim that Vesta supports Ubuntu 18.04

At your disposal for any assistance you might need.