Page 12 of 16

Re: TUTORIAL: PHP selector for PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4 for Debian & Ubuntu (and optionally directly nginx-PHP-F

Posted: Tue May 12, 2020 4:13 pm
by dpeca
MrTux wrote:
Tue May 12, 2020 3:14 pm
I installed PHP 7.4 on Ubuntu 18.04 (apache + nginx) everything works, except Roundcube which produces this error.

Going back to PHP 7.2 the error disappears.
in /etc/php/7.4/fpm/pool.d/yourdomain.com.conf file, group shold be

Code: Select all

group = www-data
Restart php-fpm after that change:

Code: Select all

service php7.4-fpm restart
But, probably roundcube will not work on PHP 7.4, so create subdomain with PHP 7.2 and use it for roundcube.

Re: TUTORIAL: PHP selector for PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4 for Debian & Ubuntu (and optionally directly nginx-PHP-F

Posted: Tue May 12, 2020 7:32 pm
by MrTux
dpeca wrote:
Tue May 12, 2020 4:13 pm
MrTux wrote:
Tue May 12, 2020 3:14 pm
I installed PHP 7.4 on Ubuntu 18.04 (apache + nginx) everything works, except Roundcube which produces this error.

Going back to PHP 7.2 the error disappears.
in /etc/php/7.4/fpm/pool.d/yourdomain.com.conf file, group shold be

Code: Select all

group = www-data
Restart php-fpm after that change:

Code: Select all

service php7.4-fpm restart
But, probably roundcube will not work on PHP 7.4, so create subdomain with PHP 7.2 and use it for roundcube.
I changed the group, now Roundcube works. Thanks!

Re: TUTORIAL: PHP selector for PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4 for Debian & Ubuntu (and optionally directly nginx-PHP-F

Posted: Tue May 19, 2020 7:18 pm
by raptor666
Hi!
I'm need requirements for open_basedir php7.4-fpm!

Code: Select all

apt-get install php7.4-apcu php7.4-mbstring php7.4-bcmath php7.4-cli php7.4-curl php7.4-fpm php7.4-gd php7.4-intl php7.4-mysql php7.4-soap php7.4-xml php7.4-zip php7.4-memcache php7.4-memcached php7.4-zip
update-rc.d php7.4-fpm defaults
a2enconf php7.4-fpm
systemctl restart apache2
cp -r /etc/php/7.4/ /root/vst_install_backups/php7.4/
rm -f /etc/php/7.4/fpm/pool.d/*
wget http://dl.mycity.tech/vesta/php-fpm-tpl/PHP-FPM-74.stpl -O /usr/local/vesta/data/templates/web/apache2/PHP-FPM-74.stpl
wget http://dl.mycity.tech/vesta/php-fpm-tpl/PHP-FPM-74.tpl -O /usr/local/vesta/data/templates/web/apache2/PHP-FPM-74.tpl
wget http://dl.mycity.tech/vesta/php-fpm-tpl/PHP-FPM-74.sh -O /usr/local/vesta/data/templates/web/apache2/PHP-FPM-74.sh
chmod a+x /usr/local/vesta/data/templates/web/apache2/PHP-FPM-74.sh

Re: TUTORIAL: PHP selector for PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4 for Debian & Ubuntu (and optionally directly nginx-PHP-F

Posted: Tue May 19, 2020 7:47 pm
by dpeca
raptor666 wrote:
Tue May 19, 2020 7:18 pm
Hi!
I'm need requirements for open_basedir php7.4-fpm!
https://github.com/myvesta/vesta/blob/m ... -74.sh#L28

php_admin_value[open_basedir] = /home/user/web/domain.com/public_html:/home/user/tmp:/bin:/usr/bin:/usr/local/bin:/var/www/html:/tmp:/usr/share:/etc/phpmyadmin:/var/lib/phpmyadmin:/etc/roundcube:/var/log/roundcube:/var/lib/roundcube

Re: TUTORIAL: PHP selector for PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4 for Debian & Ubuntu (and optionally directly nginx-PHP-F

Posted: Wed May 20, 2020 5:00 pm
by raptor666
Hi.

I use this, but unfortunately it doesn't work that way. Basedir template only.
Basedir templates look unfortunately only in php7.0.

Re: TUTORIAL: PHP selector for PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4 for Debian & Ubuntu (and optionally directly nginx-PHP-F

Posted: Wed May 20, 2020 5:08 pm
by dpeca
raptor666 wrote:
Wed May 20, 2020 5:00 pm
Hi.

I use this, but unfortunately it doesn't work that way. Basedir template only.
Basedir templates look unfortunately only in php7.0.
Not sure to understand what you are talking about.

Re: TUTORIAL: PHP selector for PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4 for Debian & Ubuntu (and optionally directly nginx-PHP-F

Posted: Wed May 20, 2020 5:14 pm
by raptor666
Open basedir only works with basedirir and the default template. (php 7.0)

However, I would need open basedir to work on php7.4 as well. But what you typed is the same for me, it doesn’t work with it.
Please compare basedir and php7.4-fpm.tpl.

Re: TUTORIAL: PHP selector for PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4 for Debian & Ubuntu (and optionally directly nginx-PHP-F

Posted: Wed May 20, 2020 6:22 pm
by dpeca
raptor666 wrote:
Wed May 20, 2020 5:14 pm
Open basedir only works with basedirir and the default template. (php 7.0)

However, I would need open basedir to work on php7.4 as well. But what you typed is the same for me, it doesn’t work with it.
Please compare basedir and php7.4-fpm.tpl.
Sorry, still don't know what you are talking about.
open_basedir value is set the same way that Vesta is doing by default.
And if you don't like, you can customize or remove it completely - just modify this line - https://github.com/myvesta/vesta/blob/m ... -74.sh#L28

I already have php7.4 on 100 servers, without any problem.

Re: TUTORIAL: PHP selector for PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4 for Debian & Ubuntu (and optionally directly nginx-PHP-F

Posted: Tue May 26, 2020 3:24 pm
by linurjob
Все работает. Спасибо.
Но я столкнулся с проблемой.
__________
http://194.х.ххх.хх/webmail/
CONFIGURATION ERROR
config.inc.php was not found.
Please read the INSTALL instructions!
___________
Чтобы решить проблему.

Удалите 8083/list/package/ шаблоны кроме default тут
http://194.х.ххх.хх:8083/list/package/

Добавьте дополнительный домен,http://194.х.ххх.хх:8083/list/web/
test.com

Web Template:default
Proxy Support:yes
SSL Support
Proxy Template:default

нажать кнопку на вашем основном домене SUSPEND

обновить страницу
http://194.х.ххх.хх/webmail/
пока не появится рабочая страница.
Далее включите свой домен!

Всем удачи. Помогайте друг другу.


Everything works. Thank you.
But I ran into a problem.
__________
http://194.х.ххх.хх/webmail/
CONFIGURATION ERROR
config.inc.php was not found.
Please read the INSTALL instructions!
___________
To solve the problem.

Remove 8083/list/package/ templates except the default here
http://194.х.ххх.хх:8083/list/package/

Add additional domain http://194.х.ххх.хх:8083/list/web/
test.com

Web Template:default
Proxy Support:yes
SSL Support
Proxy Template:default

click on your primary domain SUSPEND

refresh the page
http://194.х.ххх.хх/webmail/
until the working page.
Next, turn on your own domain!

Good luck to everyone. Help each other.The text size exceeds the maximum

Re: TUTORIAL: PHP selector for PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4 for Debian & Ubuntu (and optionally directly nginx-PHP-F

Posted: Tue May 26, 2020 3:57 pm
by dpeca
linurjob wrote:
Tue May 26, 2020 3:24 pm
Everything works. Thank you.
But I ran into a problem.
__________
http://194.х.ххх.хх/webmail/
CONFIGURATION ERROR
config.inc.php was not found.
Please read the INSTALL instructions!
___________
To solve the problem.
Thanks, but this can be fixed this way too - viewtopic.php?p=82162#p82013