Page 2 of 4

Re: Ubuntu 18.04 по каким-то причинам установка VestaCP завершается ошибкой

Posted: Tue Feb 05, 2019 5:27 pm
by LAlf
начало истории: viewtopic.php?f=29&t=18245&p=75834#p75834

Кажется смог пофиксить, правда, не знаю повалятся ли ещё какие-то баги, т.к. в конце установки всё равно вот такая фигня:
Processing triggers for systemd (237-3ubuntu10.11) ...
2019-02-05 17:17:02 [WARNING] mysql_install_db is deprecated. Please consider switching to mysqld --initialize
2019-02-05 17:17:02 [ERROR] The data directory needs to be specified.
mkdir: cannot create directory ‘/var/lib/mysql’: File exists
2019-02-05T16:17:02.506729Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2019-02-05T16:17:02.508921Z 0 [ERROR] --initialize specified but the data directory has files in it. Aborting.
2019-02-05T16:17:02.508958Z 0 [ERROR] Aborting

mysqladmin: [Warning] Using a password on the command line interface can be insecure.
Warning: Since password will be sent to server in plain text, use ssl connection to ensure password safety.
ERROR 1054 (42S22) at line 1: Unknown column 'password' in 'where clause'
mv: cannot move '/usr/local/vesta/data/ips/' to a subdirectory of itself, '/usr/local/vesta/data/ips/ХХХ.ХХХ.ХХХ.ХХХ'
sed: -e expression #1, char 0: no previous regular expression
и дальше снова строка доступа к панели с hostname, а не IP. Но хотя бы указанный файлик создался с IP, хз только чего там дальше ещё могло недоставиться или чего там sed ругался :(

Собственно, ПЕРЕД установкой весты, на голой убунте 18.04 выполнить следующее:

Code: Select all

sudo apt-get install gnupg2 curl software-properties-common net-tools
sudo add-apt-repository universe
sudo apt-get update
sudo apt-get upgrade
gnupg2 - чтоб ключик добавить, уже обсуждалось на форуме.
curl - курл по дефолну не установлен на убунте, всё равно надо ставить.
software-properties-common нужен для добавления add-apt-repository .
По факту universe не обязательно добавлять, он у меня так и так написал что "distribution component is already enabled for all sources.".
net-tools - как раз убирает ошибку которая была выше, что ifconfig в 18.04 выпилен.

А после этого ставил весту следующей командой:

Code: Select all

curl -O http://vestacp.com/pub/vst-install.sh
bash vst-install.sh --nginx yes --phpfpm yes --apache no --named no --remi no --vsftpd yes --proftpd no --iptables no --fail2ban no --quota no --exim no --dovecot no --spamassassin no --clamav no --softaculous no --mysql yes --postgresql no --hostname domain.com --email mail@yandex.com --force
Буду надеяться, что разработчики обратят внимание на то, что я написал и пофиксят баги в инсталляторе. Я пока нарна поиграюсь и не буду ставить дальше ничего, хз чего там ещё дальше могло сломаться, хапнуть горя не хочу.


------------------------------

UPD2: собственно, ЧТД. Не могу добавить SSL сертификат от CloudFlare из закрепленной темы в соседнем разделе, где я и рассказал как это делается.
Вообщем, ошибки при установке критичные всё таки.
Сейчас ещё попробую mysql базу накатить старую.

------------------------------

UPD3: в phpmyadmin ошибки:
Хранилище конфигурации phpMyAdmin не полностью настроено, некоторые расширенные функции были отключены. Узнайте причину. Или перейдите на вкладку 'Операции' любой базы данных, чтобы настроить хранилище в ней.

mysqli_real_connect(): (HY000/1045): Access denied for user 'phpmyadmin'@'localhost' (using password: YES)

Ошибка при указании соединения для controluser в конфигурации.
Последние две исчезли после применения фикса:

Code: Select all

sudo curl -O -k https://raw.githubusercontent.com/skurudo/phpmyadmin-fixer/master/pma-ubuntu.sh && sudo chmod +x pma-ubuntu.sh && sudo ./pma-ubuntu.sh
Но на странице импорта дампа теперь вот такие ошибки:
Warning in ./libraries/plugin_interface.lib.php#551
count(): Parameter must be an array or an object that implements Countable

Backtrace

./libraries/display_import.lib.php#371: PMA_pluginGetOptions(
string 'Import',
array,
)
./libraries/display_import.lib.php#456: PMA_getHtmlForImportOptionsFormat(array)
./libraries/display_import.lib.php#691: PMA_getHtmlForImport(
string '5c59c0c8e2d5d',
string 'database',
string 'admin_имябазы',
string '',
integer 2097152,
array,
NULL,
NULL,
string '',
)
./db_import.php#43: PMA_getImportDisplay(
string 'database',
string 'admin_имябазы',
string '',
integer 2097152,
)

------------------------------

UPD4: устал ковыряться, хочу работоспособный с самого начала инсталлятор, чтоб всё работало как и раньше. Готов дать разработчикам доступ к серверу с голой убунтой 18.04, если в течении суток кто-то напишет в личку (иначе снесу его).

Re: Ubuntu 18.04 по каким-то причинам установка VestaCP завершается ошибкой

Posted: Tue Feb 05, 2019 5:34 pm
by impyros
ставьте centos7 на него веста без ошибок ставится а на ubunta 18.4 всегда с ошибками (подозреваю из за введений отключения root)
еще вы не ввели предварительно
su
su -
sudo apt install gnupg gnupg2 gnupg1

Re: Ubuntu 18.04 по каким-то причинам установка VestaCP завершается ошибкой

Posted: Tue Feb 05, 2019 5:55 pm
by LAlf
impyros wrote:
Tue Feb 05, 2019 5:34 pm
ставьте centos7 на него веста без ошибок ставится а на ubunta 18.4 всегда с ошибками (подозреваю из за введений отключения root)
еще вы не ввели предварительно
su
su -
sudo apt install gnupg gnupg2 gnupg1
центос не хочу, я к убунте привык уже за долгие годы.

su
su -
не нужны

установка gnupg2 была

PS: про рут не в курсе, у меня ничего не отключено и я из под рута устанавливал как и раньше.

PPS: попробовал debian9, так там php7.0 в весте ставится...

Re: Ubuntu 18.04 по каким-то причинам установка VestaCP завершается ошибкой

Posted: Tue Feb 05, 2019 6:47 pm
by impyros
мож у тя убунта криво встала
яб тож на убунте остался но мне bill manager нужен а он под centos 7 ток
поставлю vesta на ubuntu 18.4 наверн а для хостинга пото отдельный возьму

Re: Ubuntu 18.04 по каким-то причинам установка VestaCP завершается ошибкой

Posted: Tue Feb 05, 2019 7:42 pm
by LAlf
impyros wrote:
Tue Feb 05, 2019 6:47 pm
мож у тя убунта криво встала
яб тож на убунте остался но мне bill manager нужен а он под centos 7 ток
на vm manager поставлю vesta на ubuntu 18.4 наверн
будет серв внутри серва который в серве)))))))
убунта криво встала? ) это как так бывает? :))
Я, если что, 5 раз убунту переустанавливал и накатывал весту, когда пытался сам починить.

Re: Ubuntu 18.04 по каким-то причинам установка VestaCP завершается ошибкой

Posted: Wed Feb 06, 2019 10:01 am
by LAlf
impyros wrote:
Tue Feb 05, 2019 5:34 pm
ставьте centos7 на него веста без ошибок ставится а на ubunta 18.4 всегда с ошибками (подозреваю из за введений отключения root)
Поставил центось, там вообще php5.4!!

Code: Select all

[root@serv~]# php-fpm -v
PHP 5.4.16 (fpm-fcgi) (built: Oct 30 2018 19:32:20)
А на дебиане пхп 7.0 как и писал выше, тоже неподходит.

Мне 7.2 нужен, он по бенчам все остальные версии уделывает, мне важно это

Re: Ubuntu 18.04 по каким-то причинам установка VestaCP завершается ошибкой

Posted: Wed Feb 06, 2019 12:05 pm
by gemuz
Ребята. Может кто смог к 16.04 прикрутить php 7.2, но чтобы все остальное не утвалилось?
Сам игрался с 18.04, но тоже много ошибок. Решил пока отсидеться на 16.04, но там версия 7.0.

Re: Ubuntu 18.04 по каким-то причинам установка VestaCP завершается ошибкой

Posted: Wed Feb 06, 2019 12:33 pm
by grayfolk
DigitalOcean. Чистая установка Ubuntu 18.04, перед установкой Весты никаких дополнительных действий не делал. PHP 7.2 по умолчанию.
Image

У кого на 18.04 ставится другая версия PHP - пишите в саппорт хостера.

Re: Ubuntu 18.04 по каким-то причинам установка VestaCP завершается ошибкой

Posted: Wed Feb 06, 2019 4:42 pm
by LAlf
grayfolk wrote:
Wed Feb 06, 2019 12:33 pm
DigitalOcean. Чистая установка Ubuntu 18.04, перед установкой Весты никаких дополнительных действий не делал. PHP 7.2 по умолчанию.
Image

У кого на 18.04 ставится другая версия PHP - пишите в саппорт хостера.
У меня также на другом не очень популярном хостере, без ошибок ставит и всё ок. А вот на itldc - не хочет, не знаю в чем трабл

Re: Ubuntu 18.04 по каким-то причинам установка VestaCP завершается ошибкой

Posted: Thu Feb 07, 2019 1:16 am
by impyros
дак если тебе php 7.2 надо поставь его да и все
а по бенчам всетаки 7.3 всех делает - быстрее 7.2 на 15% по отдельным тестам