Page 1 of 2

Ubuntu 18.04 - не стартует IP Tables после перезагрузки системы с VestaCP

Posted: Thu Aug 23, 2018 3:40 am
by Vladimir Chanaev
Всем привет!
Столкнулся с тем, что IP Tables отказывается стартовать при перезагрузке системы. Ручной рестарт IP Tables помогает, но это уже плохо для безопасности системы. Теперь обо всём по порядку.

Digital Ocean
Ubuntu 18.04 x64 дроплет (Ubuntu 18.04.1 LTS (GNU/Linux 4.15.0-30-generic x86_64))


Ставлю системку вот так:

Code: Select all

sudo locale-gen en_US.utf8
sudo update-locale LANG=en_US.utf8 LC_CTYPE=en_US.utf8 LC_ALL=en_US.utf8
sudo apt-key update && apt-get update && apt-get -y upgrade && apt-get dist-upgrade
sudo apt autoremove

sudo curl -O http://vestacp.com/pub/vst-install-ubuntu.sh
sudo bash vst-install-ubuntu.sh --force --nginx yes --phpfpm yes --apache no --named yes --remi yes --vsftpd no --proftpd yes --iptables yes --fail2ban yes --quota no --exim no --dovecot no --spamassassin no --clamav no --softaculous no --mysql yes --postgresql no --hostname 123456789.com --email 123456789@gmail.com --password 123456789
В конце установки VestaCP вылезают некоротые ошиби, на Ubuntu 16.04 x64 таких не было. Вот конец лога установки:

Code: Select all

Selecting previously unselected package dictionaries-common.
Preparing to unpack .../039-dictionaries-common_1.27.2_all.deb ...
Adding 'diversion of /usr/share/dict/words to /usr/share/dict/words.pre-dictionaries-common by dictionaries-common'
Unpacking dictionaries-common (1.27.2) ...
Selecting previously unselected package aspell.
Preparing to unpack .../040-aspell_0.60.7~20110707-4_amd64.deb ...
Unpacking aspell (0.60.7~20110707-4) ...
Selecting previously unselected package aspell-en.
Preparing to unpack .../041-aspell-en_2017.08.24-0-0.1_all.deb ...
Unpacking aspell-en (2017.08.24-0-0.1) ...
Selecting previously unselected package awstats.
Preparing to unpack .../042-awstats_7.6+dfsg-2_all.deb ...
Unpacking awstats (7.6+dfsg-2) ...
Selecting previously unselected package python3-ply.
Preparing to unpack .../043-python3-ply_3.11-1_all.deb ...
Unpacking python3-ply (3.11-1) ...
Selecting previously unselected package bind9utils.
Preparing to unpack .../044-bind9utils_1%3a9.11.3+dfsg-1ubuntu1.1_amd64.deb ...
Unpacking bind9utils (1:9.11.3+dfsg-1ubuntu1.1) ...
Selecting previously unselected package bind9.
Preparing to unpack .../045-bind9_1%3a9.11.3+dfsg-1ubuntu1.1_amd64.deb ...
Unpacking bind9 (1:9.11.3+dfsg-1ubuntu1.1) ...
Selecting previously unselected package binutils-common:amd64.
Preparing to unpack .../046-binutils-common_2.30-20ubuntu2~18.04_amd64.deb ...
Unpacking binutils-common:amd64 (2.30-20ubuntu2~18.04) ...
Selecting previously unselected package libbinutils:amd64.
Preparing to unpack .../047-libbinutils_2.30-20ubuntu2~18.04_amd64.deb ...
Unpacking libbinutils:amd64 (2.30-20ubuntu2~18.04) ...
Selecting previously unselected package binutils-x86-64-linux-gnu.
Preparing to unpack .../048-binutils-x86-64-linux-gnu_2.30-20ubuntu2~18.04_amd64.deb ...
Unpacking binutils-x86-64-linux-gnu (2.30-20ubuntu2~18.04) ...
Selecting previously unselected package binutils.
Preparing to unpack .../049-binutils_2.30-20ubuntu2~18.04_amd64.deb ...
Unpacking binutils (2.30-20ubuntu2~18.04) ...
Selecting previously unselected package gcc-7-base:amd64.
Preparing to unpack .../050-gcc-7-base_7.3.0-16ubuntu3_amd64.deb ...
Unpacking gcc-7-base:amd64 (7.3.0-16ubuntu3) ...
Selecting previously unselected package libisl19:amd64.
Preparing to unpack .../051-libisl19_0.19-1_amd64.deb ...
Unpacking libisl19:amd64 (0.19-1) ...
Selecting previously unselected package libmpc3:amd64.
Preparing to unpack .../052-libmpc3_1.1.0-1_amd64.deb ...
Unpacking libmpc3:amd64 (1.1.0-1) ...
Selecting previously unselected package cpp-7.
Preparing to unpack .../053-cpp-7_7.3.0-16ubuntu3_amd64.deb ...
Unpacking cpp-7 (7.3.0-16ubuntu3) ...
Selecting previously unselected package cpp.
Preparing to unpack .../054-cpp_4%3a7.3.0-3ubuntu2_amd64.deb ...
Unpacking cpp (4:7.3.0-3ubuntu2) ...
Selecting previously unselected package dbconfig-mysql.
Preparing to unpack .../055-dbconfig-mysql_2.0.9_all.deb ...
Unpacking dbconfig-mysql (2.0.9) ...
Selecting previously unselected package e2fslibs:amd64.
Preparing to unpack .../056-e2fslibs_1.44.1-1_amd64.deb ...
Unpacking e2fslibs:amd64 (1.44.1-1) ...
Selecting previously unselected package exim4-config.
Preparing to unpack .../057-exim4-config_4.90.1-1ubuntu1_all.deb ...
Unpacking exim4-config (4.90.1-1ubuntu1) ...
Selecting previously unselected package exim4-base.
Preparing to unpack .../058-exim4-base_4.90.1-1ubuntu1_amd64.deb ...
Unpacking exim4-base (4.90.1-1ubuntu1) ...
Selecting previously unselected package exim4-daemon-light.
Preparing to unpack .../059-exim4-daemon-light_4.90.1-1ubuntu1_amd64.deb ...
Unpacking exim4-daemon-light (4.90.1-1ubuntu1) ...
Selecting previously unselected package exim4.
Preparing to unpack .../060-exim4_4.90.1-1ubuntu1_all.deb ...
Unpacking exim4 (4.90.1-1ubuntu1) ...
Selecting previously unselected package libtcl8.6:amd64.
Preparing to unpack .../061-libtcl8.6_8.6.8+dfsg-3_amd64.deb ...
Unpacking libtcl8.6:amd64 (8.6.8+dfsg-3) ...
Selecting previously unselected package tcl-expect:amd64.
Preparing to unpack .../062-tcl-expect_5.45.4-1_amd64.deb ...
Unpacking tcl-expect:amd64 (5.45.4-1) ...
Selecting previously unselected package expect.
Preparing to unpack .../063-expect_5.45.4-1_amd64.deb ...
Unpacking expect (5.45.4-1) ...
Selecting previously unselected package fail2ban.
Preparing to unpack .../064-fail2ban_0.10.2-2_all.deb ...
Unpacking fail2ban (0.10.2-2) ...
Selecting previously unselected package fonts-noto-mono.
Preparing to unpack .../065-fonts-noto-mono_20171026-2_all.deb ...
Unpacking fonts-noto-mono (20171026-2) ...
Selecting previously unselected package libcc1-0:amd64.
Preparing to unpack .../066-libcc1-0_8-20180414-1ubuntu2_amd64.deb ...
Unpacking libcc1-0:amd64 (8-20180414-1ubuntu2) ...
Selecting previously unselected package libitm1:amd64.
Preparing to unpack .../067-libitm1_8-20180414-1ubuntu2_amd64.deb ...
Unpacking libitm1:amd64 (8-20180414-1ubuntu2) ...
Selecting previously unselected package libatomic1:amd64.
Preparing to unpack .../068-libatomic1_8-20180414-1ubuntu2_amd64.deb ...
Unpacking libatomic1:amd64 (8-20180414-1ubuntu2) ...
Selecting previously unselected package libasan4:amd64.
Preparing to unpack .../069-libasan4_7.3.0-16ubuntu3_amd64.deb ...
Unpacking libasan4:amd64 (7.3.0-16ubuntu3) ...
Selecting previously unselected package liblsan0:amd64.
Preparing to unpack .../070-liblsan0_8-20180414-1ubuntu2_amd64.deb ...
Unpacking liblsan0:amd64 (8-20180414-1ubuntu2) ...
Selecting previously unselected package libtsan0:amd64.
Preparing to unpack .../071-libtsan0_8-20180414-1ubuntu2_amd64.deb ...
Unpacking libtsan0:amd64 (8-20180414-1ubuntu2) ...
Selecting previously unselected package libubsan0:amd64.
Preparing to unpack .../072-libubsan0_7.3.0-16ubuntu3_amd64.deb ...
Unpacking libubsan0:amd64 (7.3.0-16ubuntu3) ...
Selecting previously unselected package libcilkrts5:amd64.
Preparing to unpack .../073-libcilkrts5_7.3.0-16ubuntu3_amd64.deb ...
Unpacking libcilkrts5:amd64 (7.3.0-16ubuntu3) ...
Selecting previously unselected package libmpx2:amd64.
Preparing to unpack .../074-libmpx2_8-20180414-1ubuntu2_amd64.deb ...
Unpacking libmpx2:amd64 (8-20180414-1ubuntu2) ...
Selecting previously unselected package libquadmath0:amd64.
Preparing to unpack .../075-libquadmath0_8-20180414-1ubuntu2_amd64.deb ...
Unpacking libquadmath0:amd64 (8-20180414-1ubuntu2) ...
Selecting previously unselected package libgcc-7-dev:amd64.
Preparing to unpack .../076-libgcc-7-dev_7.3.0-16ubuntu3_amd64.deb ...
Unpacking libgcc-7-dev:amd64 (7.3.0-16ubuntu3) ...
Selecting previously unselected package gcc-7.
Preparing to unpack .../077-gcc-7_7.3.0-16ubuntu3_amd64.deb ...
Unpacking gcc-7 (7.3.0-16ubuntu3) ...
Selecting previously unselected package gcc.
Preparing to unpack .../078-gcc_4%3a7.3.0-3ubuntu2_amd64.deb ...
Unpacking gcc (4:7.3.0-3ubuntu2) ...
Selecting previously unselected package libavahi-common-data:amd64.
Preparing to unpack .../079-libavahi-common-data_0.7-3.1ubuntu1_amd64.deb ...
Unpacking libavahi-common-data:amd64 (0.7-3.1ubuntu1) ...
Selecting previously unselected package libavahi-common3:amd64.
Preparing to unpack .../080-libavahi-common3_0.7-3.1ubuntu1_amd64.deb ...
Unpacking libavahi-common3:amd64 (0.7-3.1ubuntu1) ...
Selecting previously unselected package libavahi-client3:amd64.
Preparing to unpack .../081-libavahi-client3_0.7-3.1ubuntu1_amd64.deb ...
Unpacking libavahi-client3:amd64 (0.7-3.1ubuntu1) ...
Selecting previously unselected package libcups2:amd64.
Preparing to unpack .../082-libcups2_2.2.7-1ubuntu2.1_amd64.deb ...
Unpacking libcups2:amd64 (2.2.7-1ubuntu2.1) ...
Selecting previously unselected package libcupsimage2:amd64.
Preparing to unpack .../083-libcupsimage2_2.2.7-1ubuntu2.1_amd64.deb ...
Unpacking libcupsimage2:amd64 (2.2.7-1ubuntu2.1) ...
Selecting previously unselected package libijs-0.35:amd64.
Preparing to unpack .../084-libijs-0.35_0.35-13_amd64.deb ...
Unpacking libijs-0.35:amd64 (0.35-13) ...
Selecting previously unselected package libjbig2dec0:amd64.
Preparing to unpack .../085-libjbig2dec0_0.13-6_amd64.deb ...
Unpacking libjbig2dec0:amd64 (0.13-6) ...
Selecting previously unselected package libpaper1:amd64.
Preparing to unpack .../086-libpaper1_1.1.24+nmu5ubuntu1_amd64.deb ...
Unpacking libpaper1:amd64 (1.1.24+nmu5ubuntu1) ...
Selecting previously unselected package libgs9-common.
Preparing to unpack .../087-libgs9-common_9.22~dfsg+1-0ubuntu1.1_all.deb ...
Unpacking libgs9-common (9.22~dfsg+1-0ubuntu1.1) ...
Selecting previously unselected package libgs9:amd64.
Preparing to unpack .../088-libgs9_9.22~dfsg+1-0ubuntu1.1_amd64.deb ...
Unpacking libgs9:amd64 (9.22~dfsg+1-0ubuntu1.1) ...
Selecting previously unselected package ghostscript.
Preparing to unpack .../089-ghostscript_9.22~dfsg+1-0ubuntu1.1_amd64.deb ...
Unpacking ghostscript (9.22~dfsg+1-0ubuntu1.1) ...
Selecting previously unselected package gsfonts.
Preparing to unpack .../090-gsfonts_1%3a8.11+urwcyr1.0.7~pre44-4.4_all.deb ...
Unpacking gsfonts (1:8.11+urwcyr1.0.7~pre44-4.4) ...
Selecting previously unselected package libgc1c2:amd64.
Preparing to unpack .../091-libgc1c2_1%3a7.4.2-8ubuntu1_amd64.deb ...
Unpacking libgc1c2:amd64 (1:7.4.2-8ubuntu1) ...
Selecting previously unselected package guile-2.0-libs:amd64.
Preparing to unpack .../092-guile-2.0-libs_2.0.13+1-5ubuntu0.1_amd64.deb ...
Unpacking guile-2.0-libs:amd64 (2.0.13+1-5ubuntu0.1) ...
Selecting previously unselected package hicolor-icon-theme.
Preparing to unpack .../093-hicolor-icon-theme_0.17-2_all.deb ...
Unpacking hicolor-icon-theme (0.17-2) ...
Selecting previously unselected package idn.
Preparing to unpack .../094-idn_1.33-2.1ubuntu1_amd64.deb ...
Unpacking idn (1.33-2.1ubuntu1) ...
Selecting previously unselected package imagemagick-6.q16.
Preparing to unpack .../095-imagemagick-6.q16_8%3a6.9.7.4+dfsg-16ubuntu6.3_amd64.deb ...
Unpacking imagemagick-6.q16 (8:6.9.7.4+dfsg-16ubuntu6.3) ...
Selecting previously unselected package imagemagick.
Preparing to unpack .../096-imagemagick_8%3a6.9.7.4+dfsg-16ubuntu6.3_amd64.deb ...
Unpacking imagemagick (8:6.9.7.4+dfsg-16ubuntu6.3) ...
Selecting previously unselected package javascript-common.
Preparing to unpack .../097-javascript-common_11_all.deb ...
Unpacking javascript-common (11) ...
Selecting previously unselected package libc-dev-bin.
Preparing to unpack .../098-libc-dev-bin_2.27-3ubuntu1_amd64.deb ...
Unpacking libc-dev-bin (2.27-3ubuntu1) ...
Selecting previously unselected package linux-libc-dev:amd64.
Preparing to unpack .../099-linux-libc-dev_4.15.0-32.35_amd64.deb ...
Unpacking linux-libc-dev:amd64 (4.15.0-32.35) ...
Selecting previously unselected package libc6-dev:amd64.
Preparing to unpack .../100-libc6-dev_2.27-3ubuntu1_amd64.deb ...
Unpacking libc6-dev:amd64 (2.27-3ubuntu1) ...
Selecting previously unselected package libpixman-1-0:amd64.
Preparing to unpack .../101-libpixman-1-0_0.34.0-2_amd64.deb ...
Unpacking libpixman-1-0:amd64 (0.34.0-2) ...
Selecting previously unselected package libxcb-render0:amd64.
Preparing to unpack .../102-libxcb-render0_1.13-1_amd64.deb ...
Unpacking libxcb-render0:amd64 (1.13-1) ...
Selecting previously unselected package libxcb-shm0:amd64.
Preparing to unpack .../103-libxcb-shm0_1.13-1_amd64.deb ...
Unpacking libxcb-shm0:amd64 (1.13-1) ...
Selecting previously unselected package libxrender1:amd64.
Preparing to unpack .../104-libxrender1_1%3a0.9.10-1_amd64.deb ...
Unpacking libxrender1:amd64 (1:0.9.10-1) ...
Selecting previously unselected package libcairo2:amd64.
Preparing to unpack .../105-libcairo2_1.15.10-2_amd64.deb ...
Unpacking libcairo2:amd64 (1.15.10-2) ...
Selecting previously unselected package libhtml-tagset-perl.
Preparing to unpack .../106-libhtml-tagset-perl_3.20-3_all.deb ...
Unpacking libhtml-tagset-perl (3.20-3) ...
Selecting previously unselected package liburi-perl.
Preparing to unpack .../107-liburi-perl_1.73-1_all.deb ...
Unpacking liburi-perl (1.73-1) ...
Selecting previously unselected package libhtml-parser-perl.
Preparing to unpack .../108-libhtml-parser-perl_3.72-3build1_amd64.deb ...
Unpacking libhtml-parser-perl (3.72-3build1) ...
Selecting previously unselected package libcgi-pm-perl.
Preparing to unpack .../109-libcgi-pm-perl_4.38-1_all.deb ...
Unpacking libcgi-pm-perl (4.38-1) ...
Selecting previously unselected package libfcgi-perl.
Preparing to unpack .../110-libfcgi-perl_0.78-2build1_amd64.deb ...
Unpacking libfcgi-perl (0.78-2build1) ...
Selecting previously unselected package libcgi-fast-perl.
Preparing to unpack .../111-libcgi-fast-perl_1%3a2.13-1_all.deb ...
Unpacking libcgi-fast-perl (1:2.13-1) ...
Selecting previously unselected package libcupsfilters1:amd64.
Preparing to unpack .../112-libcupsfilters1_1.20.2-0ubuntu3_amd64.deb ...
Unpacking libcupsfilters1:amd64 (1.20.2-0ubuntu3) ...
Selecting previously unselected package libdatrie1:amd64.
Preparing to unpack .../113-libdatrie1_0.2.10-7_amd64.deb ...
Unpacking libdatrie1:amd64 (0.2.10-7) ...
Selecting previously unselected package libdbi1:amd64.
Preparing to unpack .../114-libdbi1_0.9.0-5_amd64.deb ...
Unpacking libdbi1:amd64 (0.9.0-5) ...
Selecting previously unselected package libdjvulibre-text.
Preparing to unpack .../115-libdjvulibre-text_3.5.27.1-8_all.deb ...
Unpacking libdjvulibre-text (3.5.27.1-8) ...
Selecting previously unselected package libdjvulibre21:amd64.
Preparing to unpack .../116-libdjvulibre21_3.5.27.1-8_amd64.deb ...
Unpacking libdjvulibre21:amd64 (3.5.27.1-8) ...
Selecting previously unselected package libencode-locale-perl.
Preparing to unpack .../117-libencode-locale-perl_1.05-1_all.deb ...
Unpacking libencode-locale-perl (1.05-1) ...
Selecting previously unselected package libfl2:amd64.
Preparing to unpack .../118-libfl2_2.6.4-6_amd64.deb ...
Unpacking libfl2:amd64 (2.6.4-6) ...
Selecting previously unselected package libfl-dev:amd64.
Preparing to unpack .../119-libfl-dev_2.6.4-6_amd64.deb ...
Unpacking libfl-dev:amd64 (2.6.4-6) ...
Selecting previously unselected package libgraphite2-3:amd64.
Preparing to unpack .../120-libgraphite2-3_1.3.11-2_amd64.deb ...
Unpacking libgraphite2-3:amd64 (1.3.11-2) ...
Selecting previously unselected package libntlm0:amd64.
Preparing to unpack .../121-libntlm0_1.4-8_amd64.deb ...
Unpacking libntlm0:amd64 (1.4-8) ...
Selecting previously unselected package libgsasl7:amd64.
Preparing to unpack .../122-libgsasl7_1.8.0-8ubuntu3_amd64.deb ...
Unpacking libgsasl7:amd64 (1.8.0-8ubuntu3) ...
Selecting previously unselected package libharfbuzz0b:amd64.
Preparing to unpack .../123-libharfbuzz0b_1.7.2-1ubuntu1_amd64.deb ...
Unpacking libharfbuzz0b:amd64 (1.7.2-1ubuntu1) ...
Selecting previously unselected package libhtml-template-perl.
Preparing to unpack .../124-libhtml-template-perl_2.97-1_all.deb ...
Unpacking libhtml-template-perl (2.97-1) ...
Selecting previously unselected package libtimedate-perl.
Preparing to unpack .../125-libtimedate-perl_2.3000-2_all.deb ...
Unpacking libtimedate-perl (2.3000-2) ...
Selecting previously unselected package libhttp-date-perl.
Preparing to unpack .../126-libhttp-date-perl_6.02-1_all.deb ...
Unpacking libhttp-date-perl (6.02-1) ...
Selecting previously unselected package libio-html-perl.
Preparing to unpack .../127-libio-html-perl_1.001-1_all.deb ...
Unpacking libio-html-perl (1.001-1) ...
Selecting previously unselected package liblwp-mediatypes-perl.
Preparing to unpack .../128-liblwp-mediatypes-perl_6.02-1_all.deb ...
Unpacking liblwp-mediatypes-perl (6.02-1) ...
Selecting previously unselected package libhttp-message-perl.
Preparing to unpack .../129-libhttp-message-perl_6.14-1_all.deb ...
Unpacking libhttp-message-perl (6.14-1) ...
Selecting previously unselected package libilmbase12:amd64.
Preparing to unpack .../130-libilmbase12_2.2.0-11ubuntu2_amd64.deb ...
Unpacking libilmbase12:amd64 (2.2.0-11ubuntu2) ...
Selecting previously unselected package libjs-jquery.
Preparing to unpack .../131-libjs-jquery_3.2.1-1_all.deb ...
Unpacking libjs-jquery (3.2.1-1) ...
Selecting previously unselected package libjs-underscore.
Preparing to unpack .../132-libjs-underscore_1.8.3~dfsg-1_all.deb ...
Unpacking libjs-underscore (1.8.3~dfsg-1) ...
Selecting previously unselected package libjs-sphinxdoc.
Preparing to unpack .../133-libjs-sphinxdoc_1.6.7-1ubuntu1_all.deb ...
Unpacking libjs-sphinxdoc (1.6.7-1ubuntu1) ...
Selecting previously unselected package libkyotocabinet16v5:amd64.
Preparing to unpack .../134-libkyotocabinet16v5_1.2.76-4.2_amd64.deb ...
Unpacking libkyotocabinet16v5:amd64 (1.2.76-4.2) ...
Selecting previously unselected package libopenexr22:amd64.
Preparing to unpack .../135-libopenexr22_2.2.0-11.1ubuntu1_amd64.deb ...
Unpacking libopenexr22:amd64 (2.2.0-11.1ubuntu1) ...
Selecting previously unselected package libthai-data.
Preparing to unpack .../136-libthai-data_0.1.27-2_all.deb ...
Unpacking libthai-data (0.1.27-2) ...
Selecting previously unselected package libthai0:amd64.
Preparing to unpack .../137-libthai0_0.1.27-2_amd64.deb ...
Unpacking libthai0:amd64 (0.1.27-2) ...
Selecting previously unselected package libpango-1.0-0:amd64.
Preparing to unpack .../138-libpango-1.0-0_1.40.14-1ubuntu0.1_amd64.deb ...
Unpacking libpango-1.0-0:amd64 (1.40.14-1ubuntu0.1) ...
Selecting previously unselected package libpangoft2-1.0-0:amd64.
Preparing to unpack .../139-libpangoft2-1.0-0_1.40.14-1ubuntu0.1_amd64.deb ...
Unpacking libpangoft2-1.0-0:amd64 (1.40.14-1ubuntu0.1) ...
Selecting previously unselected package libpangocairo-1.0-0:amd64.
Preparing to unpack .../140-libpangocairo-1.0-0_1.40.14-1ubuntu0.1_amd64.deb ...
Unpacking libpangocairo-1.0-0:amd64 (1.40.14-1ubuntu0.1) ...
Selecting previously unselected package libwmf0.2-7:amd64.
Preparing to unpack .../141-libwmf0.2-7_0.2.8.4-12_amd64.deb ...
Unpacking libwmf0.2-7:amd64 (0.2.8.4-12) ...
Selecting previously unselected package libmagickcore-6.q16-3-extra:amd64.
Preparing to unpack .../142-libmagickcore-6.q16-3-extra_8%3a6.9.7.4+dfsg-16ubuntu6.3_amd64.deb ...
Unpacking libmagickcore-6.q16-3-extra:amd64 (8:6.9.7.4+dfsg-16ubuntu6.3) ...
Selecting previously unselected package mailutils-common.
Preparing to unpack .../143-mailutils-common_1%3a3.4-1_all.deb ...
Unpacking mailutils-common (1:3.4-1) ...
Selecting previously unselected package libmysqlclient20:amd64.
Preparing to unpack .../144-libmysqlclient20_5.7.23-0ubuntu0.18.04.1_amd64.deb ...
Unpacking libmysqlclient20:amd64 (5.7.23-0ubuntu0.18.04.1) ...
Selecting previously unselected package libpython2.7:amd64.
Preparing to unpack .../145-libpython2.7_2.7.15~rc1-1_amd64.deb ...
Unpacking libpython2.7:amd64 (2.7.15~rc1-1) ...
Selecting previously unselected package libmailutils5:amd64.
Preparing to unpack .../146-libmailutils5_1%3a3.4-1_amd64.deb ...
Unpacking libmailutils5:amd64 (1:3.4-1) ...
Selecting previously unselected package libmemcached11:amd64.
Preparing to unpack .../147-libmemcached11_1.0.18-4.2_amd64.deb ...
Unpacking libmemcached11:amd64 (1.0.18-4.2) ...
Selecting previously unselected package libmemcachedutil2:amd64.
Preparing to unpack .../148-libmemcachedutil2_1.0.18-4.2_amd64.deb ...
Unpacking libmemcachedutil2:amd64 (1.0.18-4.2) ...
Selecting previously unselected package libnet-xwhois-perl.
Preparing to unpack .../149-libnet-xwhois-perl_0.90-4_all.deb ...
Unpacking libnet-xwhois-perl (0.90-4) ...
Selecting previously unselected package libnetpbm10.
Preparing to unpack .../150-libnetpbm10_2%3a10.0-15.3build1_amd64.deb ...
Unpacking libnetpbm10 (2:10.0-15.3build1) ...
Selecting previously unselected package libnl-3-200:amd64.
Preparing to unpack .../151-libnl-3-200_3.2.29-0ubuntu3_amd64.deb ...
Unpacking libnl-3-200:amd64 (3.2.29-0ubuntu3) ...
Selecting previously unselected package libnl-genl-3-200:amd64.
Preparing to unpack .../152-libnl-genl-3-200_3.2.29-0ubuntu3_amd64.deb ...
Unpacking libnl-genl-3-200:amd64 (3.2.29-0ubuntu3) ...
Selecting previously unselected package libpaper-utils.
Preparing to unpack .../153-libpaper-utils_1.1.24+nmu5ubuntu1_amd64.deb ...
Unpacking libpaper-utils (1.1.24+nmu5ubuntu1) ...
Selecting previously unselected package librrd8:amd64.
Preparing to unpack .../154-librrd8_1.7.0-1build1_amd64.deb ...
Unpacking librrd8:amd64 (1.7.0-1build1) ...
Selecting previously unselected package libssh2-1:amd64.
Preparing to unpack .../155-libssh2-1_1.8.0-1_amd64.deb ...
Unpacking libssh2-1:amd64 (1.8.0-1) ...
Selecting previously unselected package libzip4:amd64.
Preparing to unpack .../156-libzip4_1.1.2-1.1_amd64.deb ...
Unpacking libzip4:amd64 (1.1.2-1.1) ...
Selecting previously unselected package mailutils.
Preparing to unpack .../157-mailutils_1%3a3.4-1_amd64.deb ...
Unpacking mailutils (1:3.4-1) ...
Selecting previously unselected package manpages-dev.
Preparing to unpack .../158-manpages-dev_4.15-1_all.deb ...
Unpacking manpages-dev (4.15-1) ...
Selecting previously unselected package mc-data.
Preparing to unpack .../159-mc-data_3%3a4.8.19-1_all.deb ...
Unpacking mc-data (3:4.8.19-1) ...
Selecting previously unselected package mc.
Preparing to unpack .../160-mc_3%3a4.8.19-1_amd64.deb ...
Unpacking mc (3:4.8.19-1) ...
Selecting previously unselected package mysql-client.
Preparing to unpack .../161-mysql-client_5.7.23-0ubuntu0.18.04.1_all.deb ...
Unpacking mysql-client (5.7.23-0ubuntu0.18.04.1) ...
Selecting previously unselected package mysql-server.
Preparing to unpack .../162-mysql-server_5.7.23-0ubuntu0.18.04.1_all.deb ...
Unpacking mysql-server (5.7.23-0ubuntu0.18.04.1) ...
Selecting previously unselected package netpbm.
Preparing to unpack .../163-netpbm_2%3a10.0-15.3build1_amd64.deb ...
Unpacking netpbm (2:10.0-15.3build1) ...
Selecting previously unselected package nginx.
Preparing to unpack .../164-nginx_1.15.2-1~bionic_amd64.deb ...
----------------------------------------------------------------------

Thanks for using nginx!

Please find the official documentation for nginx here:
* http://nginx.org/en/docs/

Please subscribe to nginx-announce mailing list to get
the most important news about nginx:
* http://nginx.org/en/support.html

Commercial subscriptions for nginx are available on:
* http://nginx.com/products/

----------------------------------------------------------------------
Unpacking nginx (1.15.2-1~bionic) ...
Selecting previously unselected package php7.2-bz2.
Preparing to unpack .../165-php7.2-bz2_7.2.7-0ubuntu0.18.04.2_amd64.deb ...
Unpacking php7.2-bz2 (7.2.7-0ubuntu0.18.04.2) ...
Selecting previously unselected package php-bz2.
Preparing to unpack .../166-php-bz2_1%3a7.2+60ubuntu1_all.deb ...
Unpacking php-bz2 (1:7.2+60ubuntu1) ...
Selecting previously unselected package php-cgi.
Preparing to unpack .../167-php-cgi_1%3a7.2+60ubuntu1_all.deb ...
Unpacking php-cgi (1:7.2+60ubuntu1) ...
Selecting previously unselected package php7.2-curl.
Preparing to unpack .../168-php7.2-curl_7.2.7-0ubuntu0.18.04.2_amd64.deb ...
Unpacking php7.2-curl (7.2.7-0ubuntu0.18.04.2) ...
Selecting previously unselected package php-curl.
Preparing to unpack .../169-php-curl_1%3a7.2+60ubuntu1_all.deb ...
Unpacking php-curl (1:7.2+60ubuntu1) ...
Selecting previously unselected package php-fpm.
Preparing to unpack .../170-php-fpm_1%3a7.2+60ubuntu1_all.deb ...
Unpacking php-fpm (1:7.2+60ubuntu1) ...
Selecting previously unselected package php7.2-gd.
Preparing to unpack .../171-php7.2-gd_7.2.7-0ubuntu0.18.04.2_amd64.deb ...
Unpacking php7.2-gd (7.2.7-0ubuntu0.18.04.2) ...
Selecting previously unselected package php-gd.
Preparing to unpack .../172-php-gd_1%3a7.2+60ubuntu1_all.deb ...
Unpacking php-gd (1:7.2+60ubuntu1) ...
Selecting previously unselected package php-php-gettext.
Preparing to unpack .../173-php-php-gettext_1.0.12-0.1_all.deb ...
Unpacking php-php-gettext (1.0.12-0.1) ...
Selecting previously unselected package php-phpseclib.
Preparing to unpack .../174-php-phpseclib_2.0.9-1_all.deb ...
Unpacking php-phpseclib (2.0.9-1) ...
Selecting previously unselected package php7.2-pspell.
Preparing to unpack .../175-php7.2-pspell_7.2.7-0ubuntu0.18.04.2_amd64.deb ...
Unpacking php7.2-pspell (7.2.7-0ubuntu0.18.04.2) ...
Selecting previously unselected package php-pspell.
Preparing to unpack .../176-php-pspell_1%3a7.2+60ubuntu1_all.deb ...
Unpacking php-pspell (1:7.2+60ubuntu1) ...
Selecting previously unselected package php-tcpdf.
Preparing to unpack .../177-php-tcpdf_6.2.13+dfsg-1ubuntu1_all.deb ...
Unpacking php-tcpdf (6.2.13+dfsg-1ubuntu1) ...
Selecting previously unselected package php7.2-zip.
Preparing to unpack .../178-php7.2-zip_7.2.7-0ubuntu0.18.04.2_amd64.deb ...
Unpacking php7.2-zip (7.2.7-0ubuntu0.18.04.2) ...
Selecting previously unselected package php-zip.
Preparing to unpack .../179-php-zip_1%3a7.2+60ubuntu1_all.deb ...
Unpacking php-zip (1:7.2+60ubuntu1) ...
Selecting previously unselected package proftpd-basic.
Preparing to unpack .../180-proftpd-basic_1.3.5e-1build1_amd64.deb ...
Unpacking proftpd-basic (1.3.5e-1build1) ...
Selecting previously unselected package proftpd-doc.
Preparing to unpack .../181-proftpd-doc_1.3.5e-1build1_all.deb ...
Unpacking proftpd-doc (1.3.5e-1build1) ...
Selecting previously unselected package python3-pyinotify.
Preparing to unpack .../182-python3-pyinotify_0.9.6-1_all.deb ...
Unpacking python3-pyinotify (0.9.6-1) ...
Selecting previously unselected package libtirpc1:amd64.
Preparing to unpack .../183-libtirpc1_0.2.5-1.2_amd64.deb ...
Unpacking libtirpc1:amd64 (0.2.5-1.2) ...
Selecting previously unselected package quota.
Preparing to unpack .../184-quota_4.04-2ubuntu0.1_amd64.deb ...
Unpacking quota (4.04-2ubuntu0.1) ...
Selecting previously unselected package rssh.
Preparing to unpack .../185-rssh_2.3.4-7_amd64.deb ...
Unpacking rssh (2.3.4-7) ...
Selecting previously unselected package tcl8.6.
Preparing to unpack .../186-tcl8.6_8.6.8+dfsg-3_amd64.deb ...
Unpacking tcl8.6 (8.6.8+dfsg-3) ...
Selecting previously unselected package unzip.
Preparing to unpack .../187-unzip_6.0-21ubuntu1_amd64.deb ...
Unpacking unzip (6.0-21ubuntu1) ...
Selecting previously unselected package vesta.
Preparing to unpack .../188-vesta_0.9.8-22_amd64.deb ...
Unpacking vesta (0.9.8-22) ...
Selecting previously unselected package vesta-php.
Preparing to unpack .../189-vesta-php_0.9.8-22_amd64.deb ...
Unpacking vesta-php (0.9.8-22) ...
Selecting previously unselected package vesta-ioncube.
Preparing to unpack .../190-vesta-ioncube_0.9.8-21_amd64.deb ...
Unpacking vesta-ioncube (0.9.8-21) ...
Selecting previously unselected package vesta-nginx.
Preparing to unpack .../191-vesta-nginx_0.9.8-22_amd64.deb ...
Unpacking vesta-nginx (0.9.8-22) ...
Selecting previously unselected package whois.
Preparing to unpack .../192-whois_5.3.0_amd64.deb ...
Unpacking whois (5.3.0) ...
Selecting previously unselected package zip.
Preparing to unpack .../193-zip_3.0-11build1_amd64.deb ...
Unpacking zip (3.0-11build1) ...
Selecting previously unselected package phpmyadmin.
Preparing to unpack .../194-phpmyadmin_4%3a4.6.6-5_all.deb ...
Unpacking phpmyadmin (4:4.6.6-5) ...
Selecting previously unselected package rrdtool.
Preparing to unpack .../195-rrdtool_1.7.0-1build1_amd64.deb ...
Unpacking rrdtool (1.7.0-1build1) ...
Setting up libquadmath0:amd64 (8-20180414-1ubuntu2) ...
Setting up libgs9-common (9.22~dfsg+1-0ubuntu1.1) ...
Setting up libhtml-tagset-perl (3.20-3) ...
Setting up libgomp1:amd64 (8-20180414-1ubuntu2) ...
Setting up libjs-jquery (3.2.1-1) ...
Setting up libpaper1:amd64 (1.1.24+nmu5ubuntu1) ...

Creating config file /etc/papersize with new version
Setting up php-tcpdf (6.2.13+dfsg-1ubuntu1) ...
Setting up libatomic1:amd64 (8-20180414-1ubuntu2) ...
Setting up imagemagick-6-common (8:6.9.7.4+dfsg-16ubuntu6.3) ...
Setting up fail2ban (0.10.2-2) ...
Created symlink /etc/systemd/system/multi-user.target.wants/fail2ban.service → /lib/systemd/system/fail2ban.service.
invoke-rc.d: policy-rc.d denied execution of start.
Processing triggers for ufw (0.35-5) ...
Setting up fonts-droid-fallback (1:6.0.1r16-1.1) ...
Setting up libpaper-utils (1.1.24+nmu5ubuntu1) ...
Setting up libdbi1:amd64 (0.9.0-5) ...
Setting up libcc1-0:amd64 (8-20180414-1ubuntu2) ...
Setting up libxcb-render0:amd64 (1.13-1) ...
Setting up libevent-core-2.1-6:amd64 (2.1.8-stable-4build1) ...
Setting up libjs-underscore (1.8.3~dfsg-1) ...
Setting up e2fslibs:amd64 (1.44.1-1) ...
Setting up exim4-config (4.90.1-1ubuntu1) ...
Adding system-user for exim (v4)
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for ureadahead (0.100.0-20) ...
Setting up gsfonts (1:8.11+urwcyr1.0.7~pre44-4.4) ...
Setting up libencode-locale-perl (1.05-1) ...
Setting up vesta (0.9.8-22) ...
Setting up libtimedate-perl (2.3000-2) ...
Setting up liblcms2-2:amd64 (2.9-1) ...
Setting up libjbig0:amd64 (2.1-3.1build1) ...
Setting up libaspell15:amd64 (0.60.7~20110707-4) ...
Setting up fonts-dejavu-core (2.37-1) ...
Setting up poppler-data (0.4.8-2) ...
Setting up libdjvulibre-text (3.5.27.1-8) ...
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Setting up python3-libapparmor (2.12-4ubuntu5) ...
Setting up vesta-nginx (0.9.8-22) ...
invoke-rc.d: policy-rc.d denied execution of start.
Setting up libtsan0:amd64 (8-20180414-1ubuntu2) ...
Setting up libnetpbm10 (2:10.0-15.3build1) ...
Setting up emacsen-common (2.0.8) ...
Setting up libio-html-perl (1.001-1) ...
Setting up mc-data (3:4.8.19-1) ...
Setting up unzip (6.0-21ubuntu1) ...
Setting up linux-libc-dev:amd64 (4.15.0-32.35) ...
Setting up whois (5.3.0) ...
Setting up libgc1c2:amd64 (1:7.4.2-8ubuntu1) ...
Setting up libjs-sphinxdoc (1.6.7-1ubuntu1) ...
Setting up libdatrie1:amd64 (0.2.10-7) ...
Setting up libjpeg-turbo8:amd64 (1.5.2-0ubuntu5.18.04.1) ...
Setting up proftpd-doc (1.3.5e-1build1) ...
Setting up m4 (1.4.18-1) ...
Setting up libmemcached11:amd64 (1.0.18-4.2) ...
Setting up exim4-base (4.90.1-1ubuntu1) ...
exim: DB upgrade, deleting hints-db
Setting up libfftw3-double3:amd64 (3.3.7-1) ...
Setting up vesta-php (0.9.8-22) ...
[....] Restarting vesta (via systemctl): vesta.serviceJob for vesta.service failed because the control process exited with error code.
See "systemctl status vesta.service" and "journalctl -xe" for details.
 failed!
Setting up zip (3.0-11build1) ...
Setting up nginx (1.15.2-1~bionic) ...
invoke-rc.d: policy-rc.d denied execution of start.
Created symlink /etc/systemd/system/multi-user.target.wants/nginx.service → /lib/systemd/system/nginx.service.
Setting up python3-apparmor (2.12-4ubuntu5) ...
Setting up fonts-noto-mono (20171026-2) ...
Setting up libgraphite2-3:amd64 (1.3.11-2) ...
Setting up liblsan0:amd64 (8-20180414-1ubuntu2) ...
Setting up libzip4:amd64 (1.1.2-1.1) ...
Setting up gcc-7-base:amd64 (7.3.0-16ubuntu3) ...
Setting up binutils-common:amd64 (2.30-20ubuntu2~18.04) ...
Setting up libilmbase12:amd64 (2.2.0-11ubuntu2) ...
Setting up libsodium23:amd64 (1.0.16-2) ...
Setting up liblqr-1-0:amd64 (0.4.2-2.1) ...
Setting up libjbig2dec0:amd64 (0.13-6) ...
Setting up libmpx2:amd64 (8-20180414-1ubuntu2) ...
Setting up libntlm0:amd64 (1.4-8) ...
Setting up libpixman-1-0:amd64 (0.34.0-2) ...
Setting up libssh2-1:amd64 (1.8.0-1) ...
Setting up liblwp-mediatypes-perl (6.02-1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Setting up libaio1:amd64 (0.3.110-5) ...
Setting up ntpdate (1:4.2.8p10+dfsg-5ubuntu7.1) ...
Setting up libnet-xwhois-perl (0.90-4) ...
Setting up liburi-perl (1.73-1) ...
Setting up libtirpc1:amd64 (0.2.5-1.2) ...
Setting up php-common (1:60ubuntu1) ...
Created symlink /etc/systemd/system/timers.target.wants/phpsessionclean.timer → /lib/systemd/system/phpsessionclean.timer.
/usr/sbin/policy-rc.d returned 101, not running 'start phpsessionclean.timer'
Processing triggers for systemd (237-3ubuntu10.3) ...
Setting up libltdl7:amd64 (2.4.6-2) ...
Setting up libhtml-parser-perl (3.72-3build1) ...
Setting up libcgi-pm-perl (4.38-1) ...
Setting up libijs-0.35:amd64 (0.35-13) ...
Setting up libxcb-shm0:amd64 (1.13-1) ...
Setting up libfl2:amd64 (2.6.4-6) ...
Setting up libxpm4:amd64 (1:3.5.12-1) ...
Setting up libxrender1:amd64 (1:0.9.10-1) ...
Setting up mc (3:4.8.19-1) ...
Processing triggers for man-db (2.8.3-2) ...
Setting up libmpc3:amd64 (1.1.0-1) ...
Setting up python3-ply (3.11-1) ...
Setting up libmysqlclient20:amd64 (5.7.23-0ubuntu0.18.04.1) ...
Setting up rssh (2.3.4-7) ...
Setting up libc-dev-bin (2.27-3ubuntu1) ...
Setting up exim4-daemon-light (4.90.1-1ubuntu1) ...
invoke-rc.d: policy-rc.d denied execution of start.
Initializing GnuTLS DH parameter file
Setting up libtcl8.6:amd64 (8.6.8+dfsg-3) ...
Setting up libthai-data (0.1.27-2) ...
Setting up javascript-common (11) ...
Setting up libnl-3-200:amd64 (3.2.29-0ubuntu3) ...
Setting up mysql-client-core-5.7 (5.7.23-0ubuntu0.18.04.1) ...
Setting up idn (1.33-2.1ubuntu1) ...
Setting up manpages-dev (4.15-1) ...
Setting up hicolor-icon-theme (0.17-2) ...
Setting up dbconfig-common (2.0.9) ...

Creating config file /etc/dbconfig-common/config with new version
Setting up libc6-dev:amd64 (2.27-3ubuntu1) ...
Setting up libkyotocabinet16v5:amd64 (1.2.76-4.2) ...
Setting up awstats (7.6+dfsg-2) ...
Setting up apparmor-utils (2.12-4ubuntu5) ...
Setting up libfcgi-perl (0.78-2build1) ...
Setting up libitm1:amd64 (8-20180414-1ubuntu2) ...
Setting up libpython2.7-stdlib:amd64 (2.7.15~rc1-1) ...
Setting up python3-pyinotify (0.9.6-1) ...
Setting up libavahi-common-data:amd64 (0.7-3.1ubuntu1) ...
Setting up mailutils-common (1:3.4-1) ...
Setting up libwebp6:amd64 (0.6.1-2) ...
Setting up libjpeg8:amd64 (8c-2ubuntu8) ...
Setting up libisl19:amd64 (0.19-1) ...
Setting up bind9utils (1:9.11.3+dfsg-1ubuntu1.1) ...
Setting up libgsasl7:amd64 (1.8.0-8ubuntu3) ...
Setting up vesta-ioncube (0.9.8-21) ...
Setting up php-phpseclib (2.0.9-1) ...
Setting up fontconfig-config (2.12.6-0ubuntu2) ...
Setting up libhttp-date-perl (6.02-1) ...
Setting up php7.2-common (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/calendar.ini with new version

Creating config file /etc/php/7.2/mods-available/ctype.ini with new version

Creating config file /etc/php/7.2/mods-available/exif.ini with new version

Creating config file /etc/php/7.2/mods-available/fileinfo.ini with new version

Creating config file /etc/php/7.2/mods-available/ftp.ini with new version

Creating config file /etc/php/7.2/mods-available/gettext.ini with new version

Creating config file /etc/php/7.2/mods-available/iconv.ini with new version

Creating config file /etc/php/7.2/mods-available/pdo.ini with new version

Creating config file /etc/php/7.2/mods-available/phar.ini with new version

Creating config file /etc/php/7.2/mods-available/posix.ini with new version

Creating config file /etc/php/7.2/mods-available/shmop.ini with new version

Creating config file /etc/php/7.2/mods-available/sockets.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvmsg.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvsem.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvshm.ini with new version

Creating config file /etc/php/7.2/mods-available/tokenizer.ini with new version
Setting up libhtml-template-perl (2.97-1) ...
Setting up libasan4:amd64 (7.3.0-16ubuntu3) ...
Setting up libdjvulibre21:amd64 (3.5.27.1-8) ...
Setting up libbinutils:amd64 (2.30-20ubuntu2~18.04) ...
Setting up mysql-server-core-5.7 (5.7.23-0ubuntu0.18.04.1) ...
Setting up flex (2.6.4-6) ...
Setting up dictionaries-common (1.27.2) ...
Setting up libcilkrts5:amd64 (7.3.0-16ubuntu3) ...
Setting up php7.2-curl (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/curl.ini with new version
Setting up libubsan0:amd64 (7.3.0-16ubuntu3) ...
Setting up libmemcachedutil2:amd64 (1.0.18-4.2) ...
Setting up bind9 (1:9.11.3+dfsg-1ubuntu1.1) ...
Adding group `bind' (GID 118) ...
Done.
Adding system user `bind' (UID 114) ...
Adding new user `bind' (UID 114) with group `bind' ...
Not creating home directory `/var/cache/bind'.
wrote key file "/etc/bind/rndc.key"
Created symlink /etc/systemd/system/multi-user.target.wants/bind9.service → /lib/systemd/system/bind9.service.
/usr/sbin/policy-rc.d returned 101, not running 'start bind9-pkcs11.service bind9-resolvconf.service'
invoke-rc.d: policy-rc.d denied execution of start.
Setting up python2.7 (2.7.15~rc1-1) ...
Setting up libnl-genl-3-200:amd64 (3.2.29-0ubuntu3) ...
Setting up php-curl (1:7.2+60ubuntu1) ...
Setting up libharfbuzz0b:amd64 (1.7.2-1ubuntu1) ...
Setting up libtiff5:amd64 (4.0.9-5) ...
Setting up libthai0:amd64 (0.1.27-2) ...
Setting up proftpd-basic (1.3.5e-1build1) ...
Warning: The home dir /run/proftpd you specified can't be accessed: No such file or directory
Adding system user `proftpd' (UID 115) ...
Adding new user `proftpd' (UID 115) with group `nogroup' ...
Not creating home directory `/run/proftpd'.
Adding system user `ftp' (UID 116) ...
Adding new user `ftp' (UID 116) with group `nogroup' ...
Creating home directory `/srv/ftp' ...
'/usr/share/proftpd/templates/welcome.msg' -> '/srv/ftp/welcome.msg.proftpd-new'
invoke-rc.d: policy-rc.d denied execution of start.
Setting up libopenexr22:amd64 (2.2.0-11.1ubuntu1) ...
Setting up php7.2-mbstring (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/mbstring.ini with new version
Setting up libgcc-7-dev:amd64 (7.3.0-16ubuntu3) ...
Setting up libcgi-fast-perl (1:2.13-1) ...
Setting up cpp-7 (7.3.0-16ubuntu3) ...
Setting up libfl-dev:amd64 (2.6.4-6) ...
Setting up php7.2-bz2 (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/bz2.ini with new version
Setting up libpython-stdlib:amd64 (2.7.15~rc1-1) ...
Setting up php7.2-readline (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/readline.ini with new version
Setting up php-net-socket (1.0.14-2) ...
Setting up php-mbstring (1:7.2+60ubuntu1) ...
Setting up tcl-expect:amd64 (5.45.4-1) ...
Setting up exim4 (4.90.1-1ubuntu1) ...
Setting up guile-2.0-libs:amd64 (2.0.13+1-5ubuntu0.1) ...
Setting up tcl8.6 (8.6.8+dfsg-3) ...
Setting up libpython2.7:amd64 (2.7.15~rc1-1) ...
Setting up netpbm (2:10.0-15.3build1) ...
Setting up libhttp-message-perl (6.14-1) ...
Setting up php7.2-json (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/json.ini with new version
Setting up php7.2-intl (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/intl.ini with new version
Setting up libavahi-common3:amd64 (0.7-3.1ubuntu1) ...
Setting up mysql-client-5.7 (5.7.23-0ubuntu0.18.04.1) ...
Setting up aspell (0.60.7~20110707-4) ...
Setting up php-net-sieve (1.4.1-1) ...
Setting up php-intl (1:7.2+60ubuntu1) ...
Setting up libwmf0.2-7:amd64 (0.2.8.4-12) ...
Setting up python (2.7.15~rc1-1) ...
Setting up php7.2-opcache (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/opcache.ini with new version
Setting up binutils-x86-64-linux-gnu (2.30-20ubuntu2~18.04) ...
Setting up dbconfig-mysql (2.0.9) ...
Setting up php7.2-mysql (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/mysqlnd.ini with new version

Creating config file /etc/php/7.2/mods-available/mysqli.ini with new version

Creating config file /etc/php/7.2/mods-available/pdo_mysql.ini with new version
Setting up libmailutils5:amd64 (1:3.4-1) ...
Setting up cpp (4:7.3.0-3ubuntu2) ...
Setting up libfontconfig1:amd64 (2.12.6-0ubuntu2) ...
Setting up php7.2-xml (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/dom.ini with new version

Creating config file /etc/php/7.2/mods-available/simplexml.ini with new version

Creating config file /etc/php/7.2/mods-available/wddx.ini with new version

Creating config file /etc/php/7.2/mods-available/xml.ini with new version

Creating config file /etc/php/7.2/mods-available/xmlreader.ini with new version

Creating config file /etc/php/7.2/mods-available/xmlwriter.ini with new version

Creating config file /etc/php/7.2/mods-available/xsl.ini with new version
Setting up expect (5.45.4-1) ...
Setting up php7.2-pspell (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/pspell.ini with new version
Setting up php7.2-zip (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/zip.ini with new version
Setting up php-bz2 (1:7.2+60ubuntu1) ...
Setting up libmagickcore-6.q16-3:amd64 (8:6.9.7.4+dfsg-16ubuntu6.3) ...
Setting up php-pspell (1:7.2+60ubuntu1) ...
Setting up php-net-smtp (1.8.0-1) ...
Setting up quota (4.04-2ubuntu0.1) ...
Setting up libgd3:amd64 (2.2.5-4) ...
Setting up mysql-client (5.7.23-0ubuntu0.18.04.1) ...
Setting up roundcube-mysql (1.3.6+dfsg.1-1) ...
Setting up mailutils (1:3.4-1) ...
update-alternatives: using /usr/bin/frm.mailutils to provide /usr/bin/frm (frm) in auto mode
update-alternatives: using /usr/bin/from.mailutils to provide /usr/bin/from (from) in auto mode
update-alternatives: using /usr/bin/messages.mailutils to provide /usr/bin/messages (messages) in auto mode
update-alternatives: using /usr/bin/movemail.mailutils to provide /usr/bin/movemail (movemail) in auto mode
update-alternatives: using /usr/bin/readmsg.mailutils to provide /usr/bin/readmsg (readmsg) in auto mode
update-alternatives: using /usr/bin/dotlock.mailutils to provide /usr/bin/dotlock (dotlock) in auto mode
update-alternatives: using /usr/bin/mail.mailutils to provide /usr/bin/mailx (mailx) in auto mode
Setting up php-zip (1:7.2+60ubuntu1) ...
Setting up php-xml (1:7.2+60ubuntu1) ...
Setting up webalizer (2.23.08-3) ...
/var/www/webalizer created
Setting up php7.2-cli (7.2.7-0ubuntu0.18.04.2) ...
update-alternatives: using /usr/bin/php7.2 to provide /usr/bin/php (php) in auto mode
update-alternatives: using /usr/bin/phar7.2 to provide /usr/bin/phar (phar) in auto mode
update-alternatives: using /usr/bin/phar.phar7.2 to provide /usr/bin/phar.phar (phar.phar) in auto mode

Creating config file /etc/php/7.2/cli/php.ini with new version
Setting up aspell-en (2017.08.24-0-0.1) ...
Setting up php-pear (1:1.10.5+submodules+notgz-1ubuntu1) ...
Setting up libmagickwand-6.q16-3:amd64 (8:6.9.7.4+dfsg-16ubuntu6.3) ...
Setting up libavahi-client3:amd64 (0.7-3.1ubuntu1) ...
Setting up binutils (2.30-20ubuntu2~18.04) ...
Setting up php7.2-cgi (7.2.7-0ubuntu0.18.04.2) ...
update-alternatives: using /usr/bin/php-cgi7.2 to provide /usr/bin/php-cgi (php-cgi) in auto mode
update-alternatives: using /usr/lib/cgi-bin/php7.2 to provide /usr/lib/cgi-bin/php (php-cgi-bin) in auto mode

Creating config file /etc/php/7.2/cgi/php.ini with new version
Setting up mysql-server-5.7 (5.7.23-0ubuntu0.18.04.1) ...
invoke-rc.d: policy-rc.d denied execution of stop.
update-alternatives: using /etc/mysql/mysql.cnf to provide /etc/mysql/my.cnf (my.cnf) in auto mode
Renaming removed key_buffer and myisam-recover options (if present)
Created symlink /etc/systemd/system/multi-user.target.wants/mysql.service → /lib/systemd/system/mysql.service.
invoke-rc.d: policy-rc.d denied execution of start.
Setting up php-mysql (1:7.2+60ubuntu1) ...
Setting up fontconfig (2.12.6-0ubuntu2) ...
Regenerating fonts cache... done.
Setting up libcups2:amd64 (2.2.7-1ubuntu2.1) ...
Setting up php7.2-gd (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/mods-available/gd.ini with new version
Setting up libcairo2:amd64 (1.15.10-2) ...
Setting up php7.2-fpm (7.2.7-0ubuntu0.18.04.2) ...

Creating config file /etc/php/7.2/fpm/php.ini with new version
Created symlink /etc/systemd/system/multi-user.target.wants/php7.2-fpm.service → /lib/systemd/system/php7.2-fpm.service.
invoke-rc.d: policy-rc.d denied execution of start.
Setting up php-auth-sasl (1.0.6-3) ...
Setting up php-mail-mime (1.10.2-0.1) ...
Setting up mysql-server (5.7.23-0ubuntu0.18.04.1) ...
Setting up php-php-gettext (1.0.12-0.1) ...
Setting up gcc-7 (7.3.0-16ubuntu3) ...
Setting up php-cgi (1:7.2+60ubuntu1) ...
Setting up imagemagick-6.q16 (8:6.9.7.4+dfsg-16ubuntu6.3) ...
update-alternatives: using /usr/bin/compare-im6.q16 to provide /usr/bin/compare (compare) in auto mode
update-alternatives: using /usr/bin/compare-im6.q16 to provide /usr/bin/compare-im6 (compare-im6) in auto mode
update-alternatives: using /usr/bin/animate-im6.q16 to provide /usr/bin/animate (animate) in auto mode
update-alternatives: using /usr/bin/animate-im6.q16 to provide /usr/bin/animate-im6 (animate-im6) in auto mode
update-alternatives: using /usr/bin/convert-im6.q16 to provide /usr/bin/convert (convert) in auto mode
update-alternatives: using /usr/bin/convert-im6.q16 to provide /usr/bin/convert-im6 (convert-im6) in auto mode
update-alternatives: using /usr/bin/composite-im6.q16 to provide /usr/bin/composite (composite) in auto mode
update-alternatives: using /usr/bin/composite-im6.q16 to provide /usr/bin/composite-im6 (composite-im6) in auto mode
update-alternatives: using /usr/bin/conjure-im6.q16 to provide /usr/bin/conjure (conjure) in auto mode
update-alternatives: using /usr/bin/conjure-im6.q16 to provide /usr/bin/conjure-im6 (conjure-im6) in auto mode
update-alternatives: using /usr/bin/import-im6.q16 to provide /usr/bin/import (import) in auto mode
update-alternatives: using /usr/bin/import-im6.q16 to provide /usr/bin/import-im6 (import-im6) in auto mode
update-alternatives: using /usr/bin/identify-im6.q16 to provide /usr/bin/identify (identify) in auto mode
update-alternatives: using /usr/bin/identify-im6.q16 to provide /usr/bin/identify-im6 (identify-im6) in auto mode
update-alternatives: using /usr/bin/stream-im6.q16 to provide /usr/bin/stream (stream) in auto mode
update-alternatives: using /usr/bin/stream-im6.q16 to provide /usr/bin/stream-im6 (stream-im6) in auto mode
update-alternatives: using /usr/bin/display-im6.q16 to provide /usr/bin/display (display) in auto mode
update-alternatives: using /usr/bin/display-im6.q16 to provide /usr/bin/display-im6 (display-im6) in auto mode
update-alternatives: using /usr/bin/montage-im6.q16 to provide /usr/bin/montage (montage) in auto mode
update-alternatives: using /usr/bin/montage-im6.q16 to provide /usr/bin/montage-im6 (montage-im6) in auto mode
update-alternatives: using /usr/bin/mogrify-im6.q16 to provide /usr/bin/mogrify (mogrify) in auto mode
update-alternatives: using /usr/bin/mogrify-im6.q16 to provide /usr/bin/mogrify-im6 (mogrify-im6) in auto mode
Setting up gcc (4:7.3.0-3ubuntu2) ...
Setting up libcupsfilters1:amd64 (1.20.2-0ubuntu3) ...
Setting up libcupsimage2:amd64 (2.2.7-1ubuntu2.1) ...
Setting up php7.2 (7.2.7-0ubuntu0.18.04.2) ...
Setting up php-fpm (1:7.2+60ubuntu1) ...
Setting up libpango-1.0-0:amd64 (1.40.14-1ubuntu0.1) ...
Setting up imagemagick (8:6.9.7.4+dfsg-16ubuntu6.3) ...
Setting up php-gd (1:7.2+60ubuntu1) ...
Setting up libgs9:amd64 (9.22~dfsg+1-0ubuntu1.1) ...
Setting up roundcube-core (1.3.6+dfsg.1-1) ...
Determining localhost credentials from /etc/mysql/debian.cnf: succeeded.
dbconfig-common: writing config to /etc/dbconfig-common/roundcube.conf

Creating config file /etc/dbconfig-common/roundcube.conf with new version

Creating config file /etc/roundcube/debian-db.php with new version
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2).
unable to connect to mysql server.
error encountered creating user:
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
dbconfig-common: roundcube configure: noninteractive fail.
dbconfig-common: roundcube configure: ignoring errors from here forwards
populating database via sql...  done.
dbconfig-common: flushing administrative password
Setting up roundcube-plugins (1.3.6+dfsg.1-1) ...
Setting up ghostscript (9.22~dfsg+1-0ubuntu1.1) ...
Setting up libpangoft2-1.0-0:amd64 (1.40.14-1ubuntu0.1) ...
Setting up phpmyadmin (4:4.6.6-5) ...
Determining localhost credentials from /etc/mysql/debian.cnf: succeeded.
dbconfig-common: writing config to /etc/dbconfig-common/phpmyadmin.conf

Creating config file /etc/dbconfig-common/phpmyadmin.conf with new version

Creating config file /etc/phpmyadmin/config-db.php with new version
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2).
unable to connect to mysql server.
error encountered creating user:
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
dbconfig-common: phpmyadmin configure: noninteractive fail.
dbconfig-common: phpmyadmin configure: ignoring errors from here forwards
populating database via sql...  done.
dbconfig-common: flushing administrative password
Setting up php (1:7.2+60ubuntu1) ...
Setting up libpangocairo-1.0-0:amd64 (1.40.14-1ubuntu0.1) ...
Setting up librrd8:amd64 (1.7.0-1build1) ...
Setting up libmagickcore-6.q16-3-extra:amd64 (8:6.9.7.4+dfsg-16ubuntu6.3) ...
Setting up rrdtool (1.7.0-1build1) ...
Processing triggers for ureadahead (0.100.0-20) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for dictionaries-common (1.27.2) ...
aspell-autobuildhash: processing: en [en-common].
aspell-autobuildhash: processing: en [en-variant_0].
aspell-autobuildhash: processing: en [en-variant_1].
aspell-autobuildhash: processing: en [en-variant_2].
aspell-autobuildhash: processing: en [en-w_accents-only].
aspell-autobuildhash: processing: en [en-wo_accents-only].
aspell-autobuildhash: processing: en [en_AU-variant_0].
aspell-autobuildhash: processing: en [en_AU-variant_1].
aspell-autobuildhash: processing: en [en_AU-w_accents-only].
aspell-autobuildhash: processing: en [en_AU-wo_accents-only].
aspell-autobuildhash: processing: en [en_CA-variant_0].
aspell-autobuildhash: processing: en [en_CA-variant_1].
aspell-autobuildhash: processing: en [en_CA-w_accents-only].
aspell-autobuildhash: processing: en [en_CA-wo_accents-only].
aspell-autobuildhash: processing: en [en_GB-ise-w_accents-only].
aspell-autobuildhash: processing: en [en_GB-ise-wo_accents-only].
aspell-autobuildhash: processing: en [en_GB-ize-w_accents-only].
aspell-autobuildhash: processing: en [en_GB-ize-wo_accents-only].
aspell-autobuildhash: processing: en [en_GB-variant_0].
aspell-autobuildhash: processing: en [en_GB-variant_1].
aspell-autobuildhash: processing: en [en_US-w_accents-only].
aspell-autobuildhash: processing: en [en_US-wo_accents-only].
Processing triggers for systemd (237-3ubuntu10.3) ...
Processing triggers for ufw (0.35-5) ...
2018-08-23 03:21:10 [WARNING] mysql_install_db is deprecated. Please consider switching to mysqld --initialize
2018-08-23 03:21:10 [ERROR]   The data directory needs to be specified.
mkdir: cannot create directory ‘/var/lib/mysql’: File exists
2018-08-23T03:21:10.468017Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2018-08-23T03:21:10.469447Z 0 [ERROR] --initialize specified but the data directory has files in it. Aborting.
2018-08-23T03:21:10.469587Z 0 [ERROR] Aborting

mysqladmin: [Warning] Using a password on the command line interface can be insecure.
Warning: Since password will be sent to server in plain text, use ssl connection to ensure password safety.
ERROR 1054 (42S22) at line 1: Unknown column 'password' in 'where clause'
Setting /usr/sbin/named to complain mode.
=======================================================

 _|      _|  _|_|_|_|    _|_|_|  _|_|_|_|_|    _|_|
 _|      _|  _|        _|            _|      _|    _|
 _|      _|  _|_|_|      _|_|        _|      _|_|_|_|
   _|  _|    _|              _|      _|      _|    _|
     _|      _|_|_|_|  _|_|_|        _|      _|    _|


Congratulations, you have just successfully installed Vesta Control Panel

    https://123456789:8083
    username: admin
    password: 123456789

We hope that you enjoy your installation of Vesta. Please feel free to contact us anytime if you have any questions.
Thank you.

--
Sincerely yours
vestacp.com team

С виду всё ок, и работает. Логинимся в панель VestaCP и видим что IP Tables работает:


Перезагружаем систему любым способом. И вот оно - IP Tables не стартанул вместе с системой:


Если ткнуть Restart, то он запустится.
Глубже я не копал. Имхо уже довольно серьёзная дыра в безопасности сервера.

Могу предоставить доступ к этому тестовому дроплету, пишите.

Re: Ubuntu 18.04 - не стартует IP Tables после перезагрузки системы с VestaCP

Posted: Thu Aug 23, 2018 11:57 am
by grayfolk
Проблема известна: viewtopic.php?f=42&t=17161

Re: Ubuntu 18.04 - не стартует IP Tables после перезагрузки системы с VestaCP

Posted: Sun Sep 02, 2018 4:59 am
by Vladimir Chanaev
grayfolk wrote:
Thu Aug 23, 2018 11:57 am
Проблема известна: viewtopic.php?f=42&t=17161
Это хорошо. Надеюсь, решается. Ибо 18.04 поддержка уже заявлена, а по сути - такие вот уязвимости.

Re: Ubuntu 18.04 - не стартует IP Tables после перезагрузки системы с VestaCP

Posted: Sat Jan 12, 2019 2:00 pm
by Vladimir Chanaev
Ну что там, какие новости, решили проблему с отвалом IP Tables на Ubuntu 18.04?

Re: Ubuntu 18.04 - не стартует IP Tables после перезагрузки системы с VestaCP

Posted: Sat Feb 16, 2019 6:44 am
by Abriks
Vladimir Chanaev wrote:
Sat Jan 12, 2019 2:00 pm
Ну что там, какие новости, решили проблему с отвалом IP Tables на Ubuntu 18.04?
Нет, не решили! После ручного старта блокируется все...

Re: Ubuntu 18.04 - не стартует IP Tables после перезагрузки системы с VestaCP

Posted: Wed Mar 06, 2019 8:54 pm
by Nymphetamine
Abriks wrote:
Sat Feb 16, 2019 6:44 am
Vladimir Chanaev wrote:
Sat Jan 12, 2019 2:00 pm
Ну что там, какие новости, решили проблему с отвалом IP Tables на Ubuntu 18.04?
Нет, не решили! После ручного старта блокируется все...
У меня так же, при ручном старте или ребуте блокирует все или работает частично с некоторыми портами.
Попробуйте после ребута сервера сделать 2 раза подряд ребут iptables . После у меня начало понимать все правила.

Re: Ubuntu 18.04 - не стартует IP Tables после перезагрузки системы с VestaCP

Posted: Fri Jun 07, 2019 5:10 pm
by dao
Нет ли еще решения данного вопроса? Тоже на ubuntu 18.04 IP Tables не стартует при перезагрузке!

Re: Ubuntu 18.04 - не стартует IP Tables после перезагрузки системы с VestaCP

Posted: Fri Oct 18, 2019 12:58 pm
by Vladimir Chanaev
Ubuntu 18.04.3 (LTS) x64
IP Tables ВСЁ ЕЩЁ не стартует после перезагрузки системы с VestaCP последней версии (сейчас это 0.9.8 Release: 26)
Я это тему чуть больше года назад создал!
Зачем вы пишите поддержку Ubuntu 18.04? Если её нет, даже на таком простом уровне. Главная защита сервера слетает после простого DDoS, и делай с серваком что хочешь - ломай, спамь и т.д. .......

Re: Ubuntu 18.04 - не стартует IP Tables после перезагрузки системы с VestaCP

Posted: Fri Oct 18, 2019 1:31 pm
by grayfolk
Vladimir Chanaev wrote:
Fri Oct 18, 2019 12:58 pm
Ubuntu 18.04.3 (LTS) x64
IP Tables ВСЁ ЕЩЁ не стартует после перезагрузки системы с VestaCP последней версии (сейчас это 0.9.8 Release: 26)
Я это тему чуть больше года назад создал!
Зачем вы пишите поддержку Ubuntu 18.04? Если её нет, даже на таком простом уровне. Главная защита сервера слетает после простого DDoS, и делай с серваком что хочешь - ломай, спамь и т.д. .......
На центоси проблем нет. Бубунта всегда была кривой поделкой.

Re: Ubuntu 18.04 - не стартует IP Tables после перезагрузки системы с VestaCP

Posted: Sat Oct 19, 2019 4:44 am
by Vladimir Chanaev
dao wrote:
Fri Jun 07, 2019 5:10 pm
Нет ли еще решения данного вопроса? Тоже на ubuntu 18.04 IP Tables не стартует при перезагрузке!
Почти уверен, что проблема здесь:
/usr/local/vesta/bin/v-start-service
/usr/local/vesta/bin/v-restart-service


Там есть такой код:

Code: Select all

if [ "$service" != 'iptables' ]; then
    service $service start >/dev/null 2>&1
    check_result $? "$service start failed" $E_RESTART
else
    $BIN/v-update-firewall
    check_result $? "$service start failed" $E_RESTART
fi
Ну во-первых в Ubuntu 18.04.3 нет названия сервиса «iptables», сервис IP Tables он отображается как «ufw». Команда: sudo service --status-all. «ufw» запускается всегда при рестарте. Возможно IP Tables работает, но панель показывает сервис как не рабочий ...

Как убедиться, что IP Tables нормально функционирует в Ubuntu 18.04.3?

UPD. Вобщем, я добавил в /etc/init.d/vesta строчку в конце файла перед exit 0

Code: Select all

sudo /usr/local/vesta/bin/v-update-firewall
exit 0
И формально проблема исчезла, в панели Весты IP Tables отображается запущенным после рестарта системы.
Статистика сервиса в самой панели всё так же показывает нули (это можно вынести в отдельную проблему!):

Code: Select all

iptables
firewall
CPU: 0
Memory: 0 mb
Uptime: 0 minutes
Я хз насколько это адекватный и безопасный метод, используйте на свой страх и риск ...
И хотелось бы услышать комментарии спецов по этому решению, спасибо!