Page 1 of 1

Moodle Installation w/ Softaculous

Posted: Fri Nov 06, 2020 4:55 am
by absolutemusik
Dear all,
I am newbie for Vesta CP. Actually, I have a VPS server installed with VestaCP and using Softaculous to install Moodle 3.9.2 for education purpose.
Installation process is complete and showing me successfully installed.

Unfortunately, it shows me with the following error for accessing or (installed at root) :
Fatal error: $CFG->dataroot is not configured properly, directory does not exist or is not accessible! Exiting.

As suggested with dataroot, I have tried to edit and change path for moodledata and set the changes in the

Trial 1: /home/admin/moodledata
At CentOS, I have also tried the command for the folder
chcon -Rv -t httpd_sys_rw_content_t /home/admin/moodledata

Trial 2: copy all the moodledata to the folder with "cp -r"

Trial 3: type Linux command

For the trial 1,2,3, I have restarted the Apache + Nginx. By the way, I am using MariaDB 10.4 and PHP 7.4.12.

Actually, I have also compared my cheap shared hosting plan at the At there, it is something like /home2/xxxyyy/moodledata.

Is there anything missing? If anyone has any clues, please kindly share. Thanks in advance.


CentOS 7 / Nginx+Apache / PHP 7.4.12 / MariaDB 10.4